4 replaced http://wordpress.stackexchange.com/ with https://wordpress.stackexchange.com/
source | link

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<a href="<?php echo esc_url(get_theme_mod('slide_one_link')); ?>"><img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed AttemptFailed Attempt

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<a href="<?php echo esc_url(get_theme_mod('slide_one_link')); ?>"><img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<a href="<?php echo esc_url(get_theme_mod('slide_one_link')); ?>"><img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

3 added 66 characters in body
source | link

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<img<a href="<?php echo esc_url(get_theme_mod('slide_one_link')); ?>"><img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<a href="<?php echo esc_url(get_theme_mod('slide_one_link')); ?>"><img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

2 added 156 characters in body
source | link

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

FYI: I have tried the solution here to no avail: Failed Attempt

I'm trying to eliminate "mixed content" on my website and have done so with every area of the site except for one.

Any image uploaded via the Theme Customizer is not protocol relative nor https, all images uploaded via the customizer come up "http://".

The Customizer uses the Media Gallery uploader but doesn't seem to act in the same manner. If I upload an image to the media gallery (no customizer), place it into a page, WP knows whether or not to switch between http and https, although, when the same is attempted via the theme customizer function:

$wp_customize->add_setting('slide_img_upload_one');
$wp_customize->add_control(new WP_Customize_Image_Control($wp_customize, 'slide_img_upload_one', array(
    'label'    => __('Upload first image:', 'example_theme'),
    'section' => 'carousel_slide_section',
    'settings' => 'slide_img_upload_one',
    'description' => 'Upload your first slider image here.'
)));

I can not get the WP_Customize_Image_Control(); to output either "https" or a (best case scenario) protocol relative // url to the image for SSL compliance.

Some things to note. I'm not going to force SSL on my website so in Settings -> General; I'm not changing the url away from the http protocol.

I am also not looking for a way to use .htaccess to force this action.

Bottom line, there MUST be a way for images uploaded via the theme customizer to be protocol relative, I need some help figuring this one out though. I am currently running WP 4.6 (yes I know I'm a little behind).

Hopefully someone else has encountered this as hours of R&D have proved useless in trying to address something as specific as WordPress theme customizer func's.

Thanks in advance for any help, ideas, brainstorming... all ideas are welcome!

I am calling in the customizer function on the page using:

<img src="<?php echo esc_url( get_theme_mod( 'slide_img_upload_one' ) ); ?>" alt="<?php echo get_theme_mod( 'slide_title_1' ); ?>" /></a>

FYI: I have tried the solution here to no avail: Failed Attempt

1
source | link