2,322 reputation
1630
bio website
location Dallas, TX
age 31
visits member for 3 years, 3 months
seen yesterday

Whats there to know? A simple Geek who loves sci-fi and always up for a good challenge to solve. Hope to ask a lot of questions and hopefully get to answer some as well!


Jun
24
comment Using %postname% tag with a Custom Permastruct creates 400 Bad Request Errors from the server
Thanks for the suggestion. I did some rejiggering and as I suspected, for some reason the problem was using the built in %postname% tag. I removed it and created my own custom tag to take its place and low and behold the 400 errors went away. I have no clue why using %postname% made things go wonky, though. Maybe mixing my custom tags with %postname% is conflicting somewhere, I don't know.
Jun
24
comment Using %postname% tag with a Custom Permastruct creates 400 Bad Request Errors from the server
@TheDeadMedic. I posted the info you wanted. Hopefully that helps. I'm still pretty new with rewrite rules and how WordPress handles them. For some reason, I think the problem is with the %postname% tag because for whatever reason, whatever link I give, the server redirects to a URL with '%postname%' at the end of it. That's a big tip off for me but I don't know what it means.
Jun
24
comment A tool to analyze rewrite rules?
Question, Jan: when something is crossed out in red, what does that mean exactly?
Jun
21
comment How to get all taxonomies of a post type?
See this for more info: codex.wordpress.org/Function_Reference/get_object_taxonomies
Jun
19
comment Help with a TV series Rewrite structure
@edelwater I already have a good setup for doing the relationships between the post types, I just need help optimizing my rewrites.
Jun
15
comment Inserting Taxonomy Terms During a Plugin Activation?
Works like a charm. Thanks.
Jun
15
comment Inserting Taxonomy Terms During a Plugin Activation?
Oh so the insert didn't work because the taxonomies didn't exist yet. Gonna try this when I get home from work
Jun
15
comment Inserting Taxonomy Terms During a Plugin Activation?
@Hameedullah Khan code added for clarity on what I've tried so far.
Jun
10
comment Custom Permalinks for Custom post Type Archives?
That takes care of the rewrite but doesn't handle the actual creation of permalinks.
Jun
10
comment Custom Permalinks for Custom post Type Archives?
I want to create a more complex permalink for an archive, similar to how this article creates custom permalinks to single pages for post type: shibashake.com/wordpress-theme/…
Jun
10
comment Recommendations for an In-Depth WordPress Book?
Personally just got this one and love it. Its pretty concise and too the point.
May
18
comment Limiting posts_join, where, etc to a specific WP_Query object?
hmm, that works. Thanks, scribu. Deceptively simple coding wins again.
May
18
comment Limiting posts_join, where, etc to a specific WP_Query object?
I have two post types, one that will be sorted by a parent post title, a taxonomy and a meta vale and one by a parent post title, a taxonomy and two separate meta values. I didn't think WP was robust enough via the query args, so I'm using the post_clauses hook.
May
17
comment Using WP_Query to Query Multiple Categories with Limited Posts Per Category?
Isn't there a way to limit the join hook to only one WP_query object?
May
13
comment Usage of the new “posts_clauses” filter in Wordpress 3.1?
Cool, so it looks like at least two of the parameters passes are an array of clauses and a copy of the wp_query object being used. I wonder if there any other available arguments?
May
1
comment How to recover the post ID earlier in the WP admin hook action “firing” sequence?
It might not be available before that. Not too sure
Apr
24
comment Is there a built in function to see if a URLis oEmbed Compatible?
And thank you. That does the trick nicely
Apr
24
comment Is there a built in function to see if a URLis oEmbed Compatible?
Are those indexes regular expressions?
Mar
28
comment Ajax with OOP doesn't work
Have you found a solution to your problem? I'm trying to work with the exact same code from your metabox class and running into the same problem.
Feb
24
comment Adding a Taxonomy Filter to Admin List for a Custom Post Type?
Just stopped working for me on WordPress 3.1. Trying to figure out what exactly changed. It looks like it should still work: the taxonomy and term slugs show up as GET values in the url, but all it results in is 0 results