18 reputation
4
bio website
location
age
visits member for 2 years, 3 months
seen May 25 '12 at 16:42

May
24
comment Custom search filter causes menu and query_posts problems
@Milo - would you be willing to look at my install/theme? How could I contact you to send you an URL privately?
May
24
comment Custom search filter causes menu and query_posts problems
@Milo - This is how all search filtering snippets look in my functions.php right now - pastebin.com/reNpXK4P
May
24
comment Custom search filter causes menu and query_posts problems
@Milo - changed the query var to myprefix_type, nothing changed :(
May
24
comment Search queries don't seem to work?
...and with any custom query I have on other pages, like query_posts('post_type=organization') - displays normal posts instead of what's in the query_posts
May
24
comment Search queries don't seem to work?
It also started causing a problem with custom menus, as described here: wordpress.stackexchange.com/questions/53144/…
May
24
comment Custom search filter causes menu and query_posts problems
The code is a part of a bigger search filtering plugin/code but only this part causes problems. $types definitely doesn't include nav_menu_item
May
24
comment Custom search filter causes menu and query_posts problems
Didn't work - no change at all, menu is still gone/using fallback and removing is_admin condition messes up menu builder (Appearance->Menus - Pages section/widget)
May
24
comment Search queries don't seem to work?
any chance for last bit of help on this one? I'd be very grateful, can't figure this out :)
May
23
comment Search queries don't seem to work?
this helped passing a list of types to the query, however it started showing pages in my search results.. (I had a filter above that to only include 'post' and my custom post types: $query->set('post_type', array('post', 'typeone', 'typetwo', 'typethree')); Any reason why it suddenly started ignoring this filter? It's also set on pre_get_posts and worked with your previous snippet (with quering just one post type).
May
23
comment Search queries don't seem to work?
should this work with more than one post type sent to the query? Search for keyword (mysite.com/?s=keyword) returns two posts from two different post types. When I search for that keyword and one of the post types (mysite.com/?s=keyword&my_type=typeone) it returns the correct post (and printing the $wp_query displays all information about it). However, if i search for both post types (mysite.com/?s=keyword&my_type=typeone,typetwo) it returns nothing, no posts and nothing in $wp_query. Any ideas?
May
23
comment Search queries don't seem to work?
Fantastic! Works perfectly, thank you so much.
May
23
comment Search queries don't seem to work?
Didn't help; mysite.com/?s=lorem&post_type=myposttype still returns all post types as result. Unrelated, but it seems ?cat and ?tag suddenly started to work, so my only problem is post type now...
May
23
comment Search queries don't seem to work?
I'm not sure this will help me. I'm trying to build a more advanced search form with checkboxes for categories, post types and tags and need the URL queries to work properly. I just can't figure out why they don't.