534 reputation
318
bio website
location
age
visits member for 3 years
seen Apr 6 at 1:48

Mar
20
awarded  Curious
Mar
13
accepted getting post data in functions.php
Mar
13
comment debugging js scripts
My issue seems to have resolved itself. I added some versions to the scripts rather than leaving it blank and that seems to have gotten them working.
Mar
13
asked 2014 nested comments
Mar
4
awarded  Popular Question
Feb
24
comment debugging js scripts
I am going to take things back to the beginning to when they were working with the script tags in the header. Then I will fix things up the way you suggested by only using the wp_enqueue_function and then I will edit my post above. Give me some time to make that change. Thank you for your comments. I have found them to be helpful.
Feb
17
comment debugging js scripts
why would I get a bunch of errors saying TypeError: $ is not a function when using enqueue but I don't get any of that when using a script tag. I just don't understand why putting a script in the header works just fine yet using enqueue to do the same thing causes type errors.
Feb
17
comment debugging js scripts
I will try the wp_script_is function to see if all of them are working. I do believe they are all enqueued. I counted.
Feb
17
comment debugging js scripts
Thanks for the comments. I am working on your suggestions. I added to my question above to show more. I have tried setting the version to false in both the register and enqueue; however, the version is still there in the source code. I am calling everything from the functions.js file, wp_debug is set to true. I do not get any php errors. I have got some in firebug now and I think it might be related to the dreaded document.ready(function stuff. I have tried many different ways of wrapping these functions to get them to work
Feb
17
revised debugging js scripts
added 331 characters in body
Feb
17
asked debugging js scripts
Jan
16
revised getting post data in functions.php
removed a bad link
Jan
16
comment How to add category to: 'wp-admin/post-new.php'?
I thought by adding the code into functions.php that when I tick a category, it would add that parameter to the end of the string like in the photo above. I am trying to add a metabox to only a specific category. Then I will use $_GET to test if I am in the correct category to load the metabox. When I tried the code and tried to replicate what is in your photo above, nothing happened. All I got was wp-admin/post-new.php. I am trying to get wp-admin/post-new.php?post_cat=audio
Jan
16
comment How to add category to: 'wp-admin/post-new.php'?
I tried this solution by pasting the code into my functions.php file and it didn't work. Am I missing something? Do I need to do more like call the function to make it do the job?
Jan
15
awarded  Notable Question
Jan
15
revised getting post data in functions.php
Added more relavent information
Jan
15
answered getting post data in functions.php
Jan
15
comment getting post data in functions.php
no joy. I really don't understand this. I have this code working in a different theme on another install. Maybe something else is going on. I will have to look into it further
Jan
15
comment getting post data in functions.php
says Post not found in global space
Jan
15
comment getting post data in functions.php
no, unfortunately it isn't working. It's like the post variable is empty. The errors are gone but the metabox does not show in any category