Reputation
Next privilege 125 Rep.
Vote down
Badges
1 11
Impact
~4k people reached

  • 0 posts edited
  • 0 helpful flags
  • 6 votes cast
Oct
14
comment Problems after wp_set_password() containing an apostrophe
@CodesInChaos I think this goes way back to the time of magic quotes. Wordpress still does "addslashes" to every single $_POST and get variable there is. Knowing a little bit of Wordpress's internals doing this is pretty obvious - though getting to the point of realization cost me 6 hours of work Xx for a freaking addslashes.... Xx
Oct
14
comment Problems after wp_set_password() containing an apostrophe
@cybmeta Just to ping you again - the issue was that those functions require wp_slash() to be used. This however isn't documented, but will surely be added as now there is an open ticket for it :)
Oct
14
comment Problems after wp_set_password() containing an apostrophe
Just to ping you again - the issue was that those functions require wp_slash() to be used. This however isn't documented, but will surely be added as now there is an open ticket for it :)
Oct
14
comment Problems after wp_set_password() containing an apostrophe
@cybmeta the problem clearly lies within the usage of wp_set_password() and/or wp_update_user() - I just ran my test snipped on a naked wordpress installation. (snipped see update 3)
Oct
14
comment Problems after wp_set_password() containing an apostrophe
I am aware of this, thank you. I am using it the way it is meant to be. As far as I can tell there is two ways to update a users password. wp_set_password() and wp_update_user() - both ultimately result in the same outcome :(
Oct
14
comment Problems after wp_set_password() containing an apostrophe
@ThemesCreator correct, sorry for not being explicit enough. Please see the second update. I can only imagine this being a bug.
Apr
15
comment Custom Rewriting to Plugin with Parameters
Got it working. ?p= vs. ?page_id=. I got really confused why it kept redirecting to the page without any parameters. I noticed that internally page_id is used. So my assumption is: ?p= does an redirect to ?page_id= and strips all other stuff. I have no proof for this code-based, but ultimately with using page_id it works. Thanks for your patience!
Apr
15
comment Custom Rewriting to Plugin with Parameters
Sad news... here's what I did: Download WP (4.1.1), extract, copy myplugin.php // cd wp-dir // php -S localhost:9090 Create new Page with the given shortcode as body content. Synchronize page id within myplugin.php Enable Plugin on backend // go to Settings > Permalinks and save them a few times ("Post Name" setting) foo.dom/myplugin/123 redirects to foo.dom/myplugin with no filter being displayed.
Apr
15
comment Custom Rewriting to Plugin with Parameters
@TheDeadMedic thought this would be enough ;) However check current answer by websupporter This one doesn't work on my installation either and this is with all other plugins deactivated aside from the one-file-plugin he wrote and appears to be working on his end.
Apr
15
comment Custom Rewriting to Plugin with Parameters
Hey gyo, please see what I wrote under websupporters answer. I begin to think that the problem may be completely elsewhere as his solution doesn't work in my place with all other plugins deactivated aside from his. Added my .htaccess into the question as well, I'm really getting more n more clueless about this.
Apr
15
comment Custom Rewriting to Plugin with Parameters
OK, so I was able to test this now and sadly I get literally the same result as on my tries. Here's what I did: I copied your content to myplugin.php inside /plugins and activated the plugin on the backend. After activation i went to Setting > Permalinks and pressed Save Changes to flush the rewrite rules. I then created a new page using the shortcode [myplugin]. I went to my installation foo.dom/myplugin/123 => it redirected me to foo.dom/myplugin/ and the output was filter: - no more. :'( There's no other rewrite stuff ongoing, I disabled my plugin. My htaccess is default,too
Mar
2
comment Unable to access custom plugin backend
Too simple Xx Thank you a lot. Could you elaborate as to why the menu is still displayed using admin_init but then being inaccessible?
Mar
2
comment Unable to access custom plugin backend
@TheDeadMedic sure thing > gist.github.com/anonymous/b4f69e203630f447677b
Jul
3
comment Loop output for custom plugin [solution found]
@StephenHarris Of course, didn't really take note on the other SE-Sites lately - done ;)
Mar
22
comment Rewrite-Rules not working on a vhost, everything goes to index.php
Internally we do not use .htaccess files, we do all the configuration based on the servers vhost file (which essentially has the same effect). I simply want to get permalinks working. Which partially i did, the links worked, but i wasn't able to log in to the backend ( /wp-admin/ ) after "installing" the rewrite rule
Mar
2
comment Loop output for custom plugin [solution found]
Of course, makes a little more sense, too.