New answers tagged

-1

Copy and paste this code to functions.php file or Create a plugin and Paste this code and Activate. it will disable inline link. function my_removed_link($in){ $in['toolbar1'] = 'bold,italic,strikethrough,bullist,numlist,blockquote,hr,alignleft,aligncenter,alignright,wp_more,spellchecker,wp_fullscreen,wp_adv'; return $in; } ...


-3

This might help you in disabling this shortcuts. Try adding this on your functions.php file. function disable_mce_wptextpattern( $opt ) { if ( isset( $opt['plugins'] ) && $opt['plugins'] ) { $opt['plugins'] = explode( ',', $opt['plugins'] ); $opt['plugins'] = array_diff( $opt['plugins'] , array( 'wptextpattern' ) ); ...


5

So, I may or may not go to hell for this, but I made a quickfix plugin that bypasses the inline part and just opens the link editor. You can find it here. I didn't spend much time testing it, if you find problems make issues in github and I will see if I can fix it. The way it works is that I removed wplink as a plugin from tinyMCE, then added wplinkc, ...


0

When you hit save, open your console and log any errors. Also tick 'Preserve Log' so you can see any errors when you are changing page. Perhaps your theme is conflicting with a plugin or with wordpress.


0

that buttons are known as Quicktags, Go to Wordpress docs and search for Quicktags_API and you will get lots of default quicktags and their usages with example.


0

To display it in a template, use this: <?php /* Template Name: Template-Editor */ ?> //have to load all the scripts and header info <?php get_header(); ?> <?php $content = 'Initial content for the editor.'; $editor_id = 'editor'; $settings = array( 'wpautop' => true, //Whether to use wpautop for adding in paragraphs. Note that the ...


13

Here's a way to test the core patch #33300.6 by Andew Ozz, through a test plugin in WP 4.5.2, to try out the text pattern filter. Demo Here's a strikethrough example using ~ $init['wpsetextpattern_inline_patterns'] = '{ strong: { start: "*", end: "*", format: "bold" }, strong2: { start: "**", end: "**", format: "bold" ...


0

I just had the same problem. the submit of content of the wp_editor works not at first-submit, but perfect on second submit. Another way: Click on the html-button, and then click on the "Vusual"-Button. I do it with this jquery-statements in my jquery-code to submit the form: $("#post_content-tmce").click(); $("#post_content-html").click(); These 2 lines ...


1

After few days I got it to work. Gotta check those core files, now I know how. Anyways, here is the working code: function my_tiny_mce_tweaks( $first_init ) { $first_init['formats'] = '{' . 'alignleft: [' . '{selector: "p,h1,h2,h3,h4,h5,h6,td,th,div,ul,ol,li", styles: {textAlign:"left"}},' . '{selector: "img,table,dl.wp-caption", ...



Top 50 recent answers are included