Tag Info

New answers tagged

0

That's a bug of WordPress core: #32094 Will be fixed in 4.2.3 version of WordPress and patch is available here: 32094.patch


0

Yes, this is possible. On the link, there you create for the customizing view can you add a return parameter with the url, for this option. I mean, you must change the the link for the Customize Link in the Admin Menu. The follow demonstrate this. I create at fist a link inside the "Appearance" Menu and parse this slug to change the url to custom url, ...


0

Apparently it was the Social Media Widget plugin that caused my issue. In general, to troubleshoot such an issue with the admin page: Disable all plugins. Check that the problem has been solved, i.e., it is a plugin that causes this. Enable one plugin at a time and test, to find the culprit. Disable that plugin. Otherwise, it might be your theme. Like ...


1

If I am right, a plugin might be causing the issue. To detect the cause of problem, you must know when did this problem started occuring? Did you start after you upgraded WordPress, or after you activated a certain plugin? Also if you're using WordPress version 3.5, that version does have this issue. Check here, it should have been fixed in 3.5.1. What ...


0

They're hidden. Sign in on a desktop and enable the meta box you want to show - it's a user setting, not a device setting, so once you're done, the box will show on mobile too.


1

If the screen is less than 782px, "Screen Options" are hidden. @media screen and (max-width: 782px) { #collapse-menu, #screen-meta, #screen-meta-links, .post-format-select { display: none!important; } }


2

The best way to figure out what's happening for a problem like this is to go to the source. Literally. Take a look in wp-login.php and look for an action that fires before any HTML rendering happens. The hook you're looking for is login_init. Add a callback to it, check if the user is logged in and redirect them if so. The only other snag here is that ...


0

I had this problem in the past, and it happens sometimes when I migrate a site and forget about those changes. In my experience always is about the data base. Go to PhpMyAdmin or anywhere yo can change database tables values. Open the website's data base and find the wp_options table, open that table. Then locate the column option_name and find the values: ...


0

You can't use http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory to move from a subdomain to a domain. WordPress can be moved up or down a directory level, but the same technique can't be used for subdomain - really a different domain - to another domain. Follow Moving WordPress « WordPress Codex and WordPress Serialized PHP Search Replace Tool. ...


0

Can't be sure, but check the settings for your site in phpmyadmin, it'll list url/blog url edit this to what it should be.


1

You can check if the current page is login or not using $pagenow global variable and the wp_redirect() to custom URL within the condition is_user_logged_in function redirect_logged_in_user() { if( is_user_logged_in ) { wp_redirect('http://customurl'); } } global $pagenow; if( $pagenow == 'wp-login.php') redirect_logged_in_user();


2

Was a bug in the core, I published the ticket ( https://core.trac.wordpress.org/ticket/32310 ) and is added for the next version 4.2.3. In this version the code change the collation of some tables and this works fine if the change is fast. But in big tables this change take time, hive a timeout in the upgrade process and can't continue, so is a loop. In ...


0

Check with these options: -> Disable ALL plugins by resetting the plugin folder BY FTP. -> Change your theme to default to rules out theme level problem. -> Remove all unwanted code from htaccess -> Upgrade your Wordpress manually to the latest version


0

One for the manual update. It helped my blank wp-admin page. https://codex.wordpress.org/Updating_WordPress


0

Placing the htaccess file in the wp-admin directory did not work for me so I went a different route and it seems to be working very well. Below is what I have in my main htaccess file: <files wp-login.php> # set up rule order order deny,allow # default deny deny from all allow from x.x.x.x allow from y.y.y.y allow from z.z.z.z </files> ...


2

Try to disable the plugins via the database running this query in your MySQL: UPDATE wp_options SET option_value = 'a:0:{}' WHERE option_name = 'active_plugins'; Also, try to enable error debugging in your wp-config.php file adding this line: define( 'WP_DEBUG', true ); Also, could you paste a copy of your .htaccess file?


0

It may be caused by your .htaccess file (root directory). Try to comment it and see what happens. As it won't process your URL anymore, access your Dashboard directly like : http://yoursite.com/wp-login.php You can set a .htaccess file in every folder so check if your theme do have one too.


0

I think you are encountering a bug in _wp_translate_postdata() that makes it check edit_others_posts without providing any context for map_meta_cap and other filters to use in situations like yours (where you want a user to be able to edit specific posts that aren't theirs): https://core.trac.wordpress.org/ticket/30452#comment:5 It specifically has the ...


1

The problem is that you are enqueue the CSS file of your theme outside any of the recommended actions. If you want it to be added only in frontend, you should use wp_enqueue_scripts action: add_action( 'wp_enqueue_scripts', function() { wp_register_style( 'mainstyle', get_stylesheet_uri()); wp_enqueue_style( 'mainstyle', get_stylesheet_uri()); });


0

After a lot of guess work and research I've managed to come up with a simple solution. function column_orderby( $vars ) { $vars['orderby'] = 'date'; $vars['order'] = 'desc'; return $vars; } add_filter( 'request', 'column_orderby' ); This will sort all of the columns by 'date' as well as order them by 'desc'! Hope it helps anyone in the same ...


0

A prettier solution would be to disable the capability of creating a custom_post_type: Simply pass the the parameter 'create_posts' => false, in the capabilities array when calling register_post_type. $args = array( 'label' => __( 'Custom Post Type', 'text_domain' ), 'description' => __( 'Custom Post Type', ...


0

This worked for me: function hide_editor() { if(isset($_REQUEST['post'])){ $post_id = $_REQUEST['post']; $template_file = get_post_meta($post_id, '_wp_page_template', true); if($template_file == 'page-home.php'){ // template name here remove_post_type_support('page', 'editor'); } } } add_action( 'load-post.php', 'hide_editor' ); ...


0

Delete the .htaccess in wordpress root should bring site back up reset permalinks admin - settings - permalinks. If you don't see the htaccess file it is likely hidden you have to select show hidden files in whatever method you use to view files


1

The text you are referring to is located in here: wp-admin/nav-menus.php. But we will not edit directly. We will use functions.php for the convenience of preserving the changes after an upgrade. Use the following code in functions.php add_filter( 'gettext', 'wps_translate_words_array' ); add_filter( 'ngettext', 'wps_translate_words_array' ); function ...


0

Well I did solve this. I have downgraded the wordpress version. I uploaded the old wp files to my server. Files should be rewritten ones in the server. Then I go back to website and upgrade it. Problem solved! This is my solution no other sugessions have worked for me. And the last warning DO NOT CHANGE YOUR WEBSITE URL EVER!!!! :)


0

Here is the final solution that works for me. : function my_remove_post_locked() { $current_post_type = get_current_screen()->post_type; // Disable locking for page, post and some custom post type $post_types_arr = array( 'page', 'post', 'custom_post_type' ); if(in_array($current_post_type, ...



Top 50 recent answers are included