New answers tagged

0

Posts have a slug (that's the last part of the URL), and it must be distinct, even if posts are in different categories. If your only worry is SEO, don't worry. Google sees the URLs as distinct, and Google is used to dealing with URLs that have a suffix on them, and has no problems with it. The keywords in the URL are still the same and have the same ...


0

Is it possible that the problem is in the .htaccess file? Almost certainly. Double check that you've updated the correct .htaccess file - and that your host supports using .htaccess files! See this question for more details.


1

You can explode URL by ? and take the first part: $url = explode( '?', esc_url_raw( add_query_arg( array() ) ) ); $no_query_args = $url[0];


1

is there a way to update all media urls in wordpress I had a similar issue with my media files not having the correct file location after a Wordpress upgrade (somehow all the media links switched to a crazy incorrect directory), so I found Upload URL and Path Enabler which was able to rewrite all media URLs to a different path location where all my ...


2

WordPress tries to guess what post the user want to see by post name. That is what is making both example.com/new-bikes/ktm/duke/ktm-690-duke-2012/ and example.com/new-bikes/ktm/yamaha/ktm-690-duke-2012/ return the same and "correct" content. What is important is that, if you see at the source code of example.com/new-bikes/ktm/yamaha/ktm-690-duke-2012/, you ...


0

404 Possible Error Cases with Permalinks check your apache config and make sure the directory is right. restart the apache process along with MYSQL/similar. make sure mod_rewrite is enabled Apache mod_rewrite for Ubuntu/Debian: sudo a2enmod rewrite sudo service apache2 restart Similliar to mod_rewrite for Nginx by .htaccess: a simpler way is ...


0

This Ugly Links you call in WordPress is named Permalinks. There are many formats of Permalinks, such as: Default Day and Name Month and Name Numeric Post Name (used by most of WordPress Themes on web now-a-days) Custom Structure I didn't quite understand your question, Did you change the Permalink some how? Are you getting redirected? Or, Would like to ...


1

Settings --> Permalinks. Choose 'post name'. See the official Wordpress codex page for more.


0

I figured it out. Hours and hours of banging my head against a wall and it turns out all this needed was one simple line: ob_clean(); Somewhere in some included file there's probably one line of whitespace that is screwing things up. ob_clean() will work for now. Thanks for the effort everyone who helped!



Top 50 recent answers are included