Tag Info

New answers tagged

0

WordPress is giving you a notice that this construct is deprecated, because it is preparing for PHP7. You should check your custom code and any plug-ins for the use of the WP_Widget construct. There are (still) a lot of plug-ins that need to update their code. Here is a list of plug-ins that use the deprecated WP_Widget construct: ...


0

I think you mean "W3 Total Cache". GoTo admin panel hover on performance -> click on empty all caches. I think this may help you. And make sure all files have same name.


0

If you're updating the theme design but are not able to see the live changes and as you wrote, messed up design, you should purge the WP Total Cache. For that go to WP Total Cache and click on 'Delete Cache' or any similar option. Also, be sure to check the validity of your browser cache. You can check that in your .htaccess file.


0

If you've modified the theme's built-in stylesheet, then any changes would be overwritten when you update the theme. If that's the case, you have a choice: either don't update the theme, or move your modifications to any type of CUSTOM CSS area that the theme may provide.


0

If you want to keep WP_DEBUG on and do you want to hide this specific type of error, put in your theme functions.php this line: add_filter('deprecated_constructor_trigger_error', '__return_false'); This will prevent this kind of error to be displayed. I hope it helps :)


1

In many cases, you may use the following filter to disable local ssl verification. This is useful for self-signed certificates errors. add_filter('https_local_ssl_verify', '__return_false'); The current version v4.3.0 determins if a request is "local" with the following, in wp-includes/class-http.php // Determine if this request is to OUR install of ...


-1

Wordpress Debug mode can produce these kinds of messages. I had the same problem on one of my sites. Maybe you have this line of code on your wp-config.php file: define('WP_DEBUG', true); Try changing it to: define('WP_DEBUG', false); Hope it helps.


0

in my case, it was simply the SITE URL left blank in Settings -> General Filled with mu site URL, everything started working again. i found out enabling WP_DEBUG in wp-config.php, and i got this error: "Notice: Undefined index: host"


0

I've since found my own solution: Delete the .htaccess file in the Wordpress root directory. I've written more details in a post on my blog at cellepo.com.


0

Have you tried using the Wordpress admin panel to configure your auto-updates? You may have better luck there. It should be found under your "Dashboard > Updates". If you do not see it there, there is also the option of a plugin to help manage it for you: Automatic Updater for Wordpress


0

This is due to a missmatch between the databases versions you said you are using in the settings. Please follow this steps: Go to /wp-include/ folder and open the version.php. Find the value for $wp_db_version, and write it down. Now, open your database, check in the table called wp_options Find the db_version value: SELECT option_value FROM ...


3

The error isn't actually caused by your PHP version (PHP 4 constructors won't be removed until PHP 7) - it's a warning produced by WordPress in preparation for this. Each repetition of the error represents a plugin using the outdated code. Until your plugins' authors update them, you can run the following shell command on a Linux system to find the old ...


0

I was in a similar boat (first had to fix some custom widgets in a theme), but had the message even after fixing them. Switched to a default theme: still had the same error. TL;DR: Started deactivating plugins one-by-one... found https://wordpress.org/plugins/list-category-posts/ was the culprit.


0

I had the same issue and couldn't find a solution. So through phpmyadmin _option I started deleting rows. The third row I deleted was theme_mods_twentythirteen. Once this was gone I had no trouble again! Fingers crossed...


0

Deriving from @wyck's answer, all update notices and PHP warnings are now hidden using the script below. Just place this in your functions.php function remove_core_updates() { global $wp_version; return (object) array( 'last_checked' => time(), 'version_checked' => $wp_version, ); } add_filter('pre_site_transient_update_core', ...



Top 50 recent answers are included