Tag Info

New answers tagged

0

It looks like your'e missing the subdirectory part relative to the root setting, try this instead: try_files $uri $uri/ /wordpress/index.php?$args; and you shouldn't need the q=$uri part. For subdirectories dir1 and dir2, you could wrap the try_files with locate blocks, something like: location /dir1/ { try_files $uri $uri/ /dir1/index.php?$args; ...


2

It turns out that the nginx config that W3 Total Cache inserts if Disk Enhanced mode is enabled will break permalinks, but only if you restart nginx after W3 Total Cache injects the config for Disk Enhnaced mode. Based on birgire's suggestion, I turned off all plugins and checked the site, which started working correctly. I then turned on W3 Total Cache ...



Top 50 recent answers are included