New answers tagged

1

If the links are coming from the main content areas, you could create a hook which acts against this "content" output. In your themes functions.php file, you could try something like: add_filter('the_content', 'the_url_filter_function_name', 30); function the_url_filter_function_name($content) { return str_replace('bad-url.com', 'good-url.com', ...


0

I am using following code to make all external links no follow and this code works. add_filter('the_content', 'my_nofollow'); add_filter('the_excerpt', 'my_nofollow'); function my_nofollow($content) { return preg_replace_callback('/<a[^>]+/', 'my_nofollow_callback', $content); } function my_nofollow_callback($matches) { $link = $matches[0]; ...


0

Neither Gixty's nor Robert's code worked for me. Robert's one didn't even match correctly links, and even with the correct pattern didn't check whether the link was internal or external, and added the nofollow to all links, whereas Gixty's one correctly added the nofollow, but again to all links, not just internal ones. This is my code, which works fine ...


0

There's the plugin Rel Nofollow now, which does what needed here. Quoting its description: When a post is saved, the plugin adds the rel="nofollow" attributes to post links. The plugin also provides an apt checkbox to exclude a post from plugin's action.


0

Go to visuals when writing a post or building a page. Then use this: <img src="http://your image .jpg" /> Just copy the complete image address and paste it in between the quotes " ".


1

This is some specific shortcode to some plugin, that if you just want to paste an image in wordpress editor isn't necessary. (Also there is not enough info about what this shortcode is about). So there is simple HTML that will simply display link you want as an image, following: <img src="http://here-goes-some-url-of-your-image" /> Make sure you ...


-1

Solved.. it turns out the link dialog does not work if the body has the "modal-open" class.



Top 50 recent answers are included