Tag Info

New answers tagged

0

I found a solution. You have to go to the folder controllers/core.php and there you have to change the function get_recent_posts(). You have to add this code to remove categories that you don't want: public function get_recent_posts() { global $json_api; // get all the categories from the database $cats = get_categories(); // loop ...


0

Managed to figure it out in the end by modifying one of the core files of the plugin If you look in json-api/models/post.php there's a function set_content_value() which shows where the plugin is pulling in the content. Here you can modify it as needed, in my case I used it to remove certain shortcodes with the Wordpress remove_shortcode() function


0

This is a Wordpress setting you can change. Login to the WP admin panel, click Settings > Reading, change "Syndication feed show the most recent" from the default 10 items to something higher, and click Save. If you don't see the change immediately, try clearing the recent cache in your browser, or open the link in a different browser.


0

Solutions is to add a $page entering value to the function and in the curl route that represents the page number to end up with a route like this curl -i websitename/wp-json/posts/page_number where $page is page_number public function posts($page){ $args = array( 'author' => $id, 'posts_per_page' => 24, ...



Top 50 recent answers are included