New answers tagged

1

Migrate message is merely informational. It isn't a warning or error. It is displayed unconditionally whenever respective script is loaded. In current WP version it is loaded whenever jquery handle is requested by anything, alongside jquery-core.


0

That's called Thickbox. Since you give no clue what you want to use it for, you'll have to figure out the rest for yourself...


1

First, don't echo your php, but assemble everything in a string, let's say $titlestring. Next, make this string available for access by the javascript (the slug is the one you used to register the script): $params = array ( 'titlestring' => $titlestring, ); wp_localize_script ('your-script-slug', 'IframeTitle', $params); Finally, access the ...


0

Milo is correct. For instance, go to your theme's functions.php file, and add the following: add_filter( 'allowed_http_origins', 'add_allowed_origins' ); function add_allowed_origins( $origins ) { $origins[] = 'https://site1.example.com'; $origins[] = 'https://site2.example.com'; return $origins; } Now an ajax call from ...


-1

Use jQuery instead of $. e.g use jQuery('.parallax') instead of $('.parallax').


-2

One simple way of doing this would be by creating new page template for those pages. Follow the procedure copy your page.php file and give it a name i.e. no_script.php Then in the top line replace function name as get_header(); with you actual header.php code (Mean simply paste you whole header.php code by replacing get_header();). Remove header script ...


0

I know nothing about the theme or plugins you are using. Since your theme isn't responsive you could get away with the down and dirty approach if you can edit CSS files: /wp-content/themes/mytable/style.css line 262 .content-bar { border-right: none; width: 890px; } /wp-content/themes/mytable/style.css line 181 .right-sidebar { display: none; } Or ...


0

Put your script code like this <?php wp_head(); ?> <script type="text/javascript"src="http://cdn.mathjax.org/mathjax/latest/MathJax.js?config=TeX-AMS-MML_HTMLorMML"> </script> <script type="text/x-mathjax-config"> MathJax.Hub.Config({ extensions: ["tex2jax.js"], jax: ["input/TeX", "output/HTML-CSS"], ...


0

I could understand what the problem was. Firstly the statement<script type="text/javascript"src="http://cdn.mathjax.org/mathjax/latest/MathJax.js?config=TeX-AMS-MML_HTMLorMML"> was inside an if for the browser IE. Even after removing that I faced the same problem because I had WP cache enabled and this was caching my webpages. So when you are testing ...


0

These three lines work as expected , There is a problem maybe with other code before these lines that prevent the execution of your script; In case just fire the browser console in this page and try them here $( "html" ).append( "<div id='bf_rsvp_note_display'></div>" ); $( "body" ).append( "<div id='bf_rsvp_note_display'></div>" ...


1

I had 2 things wrong: I unregistered wordpress's jquery without properly registering my own (I concatenated my scripts ) I didnt have wp_footer() in my theme. the wp_enqueue_media() function loads the scripts to the footer.



Top 50 recent answers are included