Tag Info

Hot answers tagged

2

First of all i'd recommend you stop using title attribute for html container purpose: Image title (and the element name speaks for itself) should provide additional information and follow the rules of the regular title: it should be relevant, short, catchy, and concise (a title “offers advisory information about the element for which it is set“). ...


2

This is a good idea. Thanks for suggesting it—going to use it. :) You can add a column to the Media Library that outputs the paths. This will spit them all out. You could of course filter it to only show the sizes you actually want. Put in functions.php or similar. // Adds a "Sizes" column function sizes_column( $cols ) { $cols["sizes"] = "Sizes"; ...


1

The fact that basic WP functionality wont provide you a panel to manage those sizes and retrieve media links. You can continue using a a_full_url/image.150x150.ext, or: 1) Go-to any post/page entity via admin panel. Use 'Add image' function 2) Select a specific size that you need and apply image 3) Goto "Text" editor mode of the same post and find ...


1

It's only a guess, but it's also most probable cause... When you upload an image to WP, some metadata is generated and stored in database. This metadata contains such info like name, path and size of the image (to be more precise - paths and sizes of all created images based on uploaded one). And... This metadata is stored as serialized array. When the ...


1

I found that what was causing this issue was a plugin I had enabled that was supposed to handle retina images called WP Retina 2X. I disabled the plugin and it immediately fixed the issue.


1

The WP function get_attached_media() should provide the info you need. If used in this way... $media = get_attached_media( 'image' ); ... the $media var should contain the wp_post objects for all attached images. Function documentation in the WP Codex: https://codex.wordpress.org/Function_Reference/get_attached_media


1

If you are uploading images the same size as the large size in your WordPress installation, then set your Large size to 0x0 in Settings -> Media or remove this line: add_image_size( 'large-size', $LARGE_SIZE, 9999 ); EDIT #1: Try to add this filter to delete the original image: add_filter('wp_generate_attachment_metadata', 'delete_fullsize_image'); ...



Only top voted, non community-wiki answers of a minimum length are eligible