Tag Info

Hot answers tagged

6

$_SERVER['REQUEST_URI'] will not be empty in WordPress, because it is filled in wp_fix_server_vars() (file wp-includes/load.php). This function is called in wp-settings.php before any plugin is loaded. So you can use it. But always escape the value. It is global and can be changed by any other code, so you cannot trust its value.


4

There's really great WordPress codex article Before You Create A Network, "Do you really need a network?" part will answer most of your questions.


4

Attachments are stored with their filename (minus extension) as the post name. So if you uploaded an attachment that's called map.xyz, it would have the same name as your page. So first, check your Media Library if you have a 'map' attachment. Secondly, check if your 'map' page still exists and still has the same slug. When wordpress tries to resolve your ...


3

Add a rewrite endpoint to give your plugin a public URL- function wpa_my_endpoint(){ add_rewrite_endpoint( 'my_api', EP_ROOT ); } add_action( 'init', 'wpa_my_endpoint' ); After you flush rewrite rules, you'll have the URL available for the scheduler to ping. http://example.com/my_api/do/something/ Then catch those requests on the parse_query ...


2

FTP credentials are fallback for when writing directly to the file system is not available. Naturally they take active FTP (or SSH) server - which is typical for any hosting out there, but not necessarily part of local installation. Essentially you have two options: Troubleshoot why direct file system access is not available to your WP installation. On ...


2

You could also try this. On the application pool that is using the blog, change the identity to LocalSystem, then on Sites, Choose your wpblog Right Click and click on Edit permissions On security tab, add authenticated users With that, WP should update without the need of FTP Passwords... Basically you just give read/write permission to an ...


2

I am not entirely sure that it would work with sub-sub-domains. :) Most of your requirements (IIS aside) seem very manageable: consistent design would be easy to achieve with shared theme (or several child themes if required); users can be easily assigned to multiple sites, using single login and account (through editing site in Network Admin).


2

You are encountering an improperly configured server. Please consult the Wordpress manual on how to setup wordpress on a windows server system. AFAIK - but I'm not a windows server expert - you must configure the upload directory that the user executing the PHP Wordpress application is able to access files therein for reading, writing, creating and ...


2

This resolved my 404 error. I essentially went into IIS and directed the 404s to a custom URL “/index.php?error=404“ Article that explained how to resolve the error


2

Go resave your Permalink settings to correct the .htaccess file. Multisite systems have a slightly different .htaccess configuration. Specifically, they have this line in them: # uploaded files RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L] That lets the /files/whatever URLs get routed to the proper location. Edit: sorry, ...


1

Have you verified permissions on the upload_tmp_dir (C:\Temp)? It's possible that the upload is actually failing there rather than in the destination directory.


1

Yes, you can definitely run it with the two URLs on the same box. The only reason I've ever seen against doing this is to avoid getting a duplicate content penalty from search engines. I've never done this on a Windows box, only Linux; however, assuming you can get both URLs to get to the same installation, the rest is platform-agnostic. Here's how I do ...


1

The type of permalinks you write about are also called "Pretty Permalinks" and are a feature of Wordpress that has been designed for the Apache HTTP Server with Mod_Rewrite enabled. Every other server is at first incompatible to this and you should not use those pretty permalinks on those system unless you know what you are doing. There are replacements for ...


1

Documentation on Using Permalinks suggest this post for setting them up on IIS 6.


1

see: WordPress 3.0.1 on IIS 6 Web Server PermaLink Issues


1

The 404 is typical of WP thinking it has got no posts. Seeing that you actually have posts, I'm prompted to ask if you've plugins that mess around with query arguments or that override the loop partially or entirely? If so, they might be missing a few lines of code to allow WP to "know" it has found posts.


1

It wasn't a problem of IIS Server it was a Wordpress Bug. By upgrading Wordpress it didn't happen again.


1

At the very end of your wp-config.php file insert the following code; if(is_admin()) { add_filter('filesystem_method', create_function('$a', 'return "direct";' )); define( 'FS_CHMOD_DIR', 0751 ); } Save then try again


1

Check out your php.ini config file and try changing the permissions for your upload_tmp_dir & session.save_path directories.


1

I had the same problem. When auto-updating, certain files would get "locked" somehow stopping the rest of the update process. Are you using Windows cache extension for PHP by any chance? Read the following post: http://ruslany.net/2011/04/wincache-and-wordpress-plugin-upgrade-problem/


1

This sounds like your domain doesn't match the cookie being generated. It may not have anything to do with the IP. define( 'DOMAIN_CURRENT_SITE', 'svr-web-csrms' ); I would expect an actual domain or something, like this. define( 'DOMAIN_CURRENT_SITE', 'subdomain.mysite.tld' ); I tried to look at your web.config - but it appears that the URL is now ...


1

Judging by your screenshot, the plugin has some basic code errors and you run your installation with define('WP_DEBUG', true);. Turn the debug mode and other ways for error reporting off and see if it works now. If it doesn’t, use another plugin or wait for the developer to fix it.


1

I had the same problem. From my log file I can see its breaking on the query that returns the posts. I managed to get this working by going to "wp-includes\query.php", and then removing the $limits variable from the query. It seems that this is breaking on sql server. Find this line: $this->request = " SELECT $found_rows $distinct $fields FROM ...


1

I don't see an issue. For all hosting intents and purposes word.example.com would be completely different domain to www.example.com. Just point it to WP server (using your hosting or domain registrar, depending on your domain setup) and business as usual from there.


1

You can filter home_url: add_filter( 'home_url', 'wpse102523_home_url' ); function wpse102523_home_url( $url ) { return $url . 'index.php/'; } Reference: Adam Brown's Filter Database


1

This turned out to be a permissions issue. It seems that in order for './your_filename.php' to work, the user PHP is running as needs to have 'List folder contents' permissions on the folder - even though the file is directly specified. In the end, the full solution involved turning Fast CGI impersonation off, getting PHP to run as the Application Pool ...


1

Yes, because you did not change all domain URL values stored in database, mostly on posts. There are two solutions. (second one is recommended) Either define these variables in wp-config.php. These will override any domain URL values stored in database. define( 'WP_HOME', 'http://173.214.165.83' ); define( 'WP_SITEURL', 'http://173.214.165.83' ); This ...


1

Analysing the Error WordPress database error 42000 : [Microsoft][SQL Server Native Client 10.0][SQL Server]Incorrect syntax near 'wp_users'. for query SELECT TABLE_NAME FROM INFORMATION_SCHEMA.TABLES WHERE TABLE_NAME LIKE ''wp_users'' made by display_setup_form, pdo_wpdb->query, pdo_wpdb->_post_query, pdo_wpdb->print_error …reads as: SELECT ...



Only top voted, non community-wiki answers of a minimum length are eligible