Tag Info

New answers tagged

0

It turns out that the problem wasn't WP per say but that mod_rewrite was being forbidden because of some server settings. I didn't realize it until the server guy sent over an error log that was filled with messages containing: Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden To make it work, he ...


0

Most of the time this problem gets solved after flushing the permalinks. By that I mean, one just needs to hit 'Save changes' on 'Permalink settings' page on backend. However you said that you tried pretty permalinks and its not working. Under "Settings > General", please confirm that you have updated "WordPress Address (URL)" and "Site Address (URL)" to ...


0

If you want wordpress to behave nice when asked to serve content from example.com you need to configure it to know that. This is done automatically at the install process for the domain on which wordpress is installed on but can also be controlled from wp-config.php by setting values to the WP_HOME and WP_SITEURL constants. What you need to do is set the ...


0

You can use this code in your .htaccess file to achieve what you want. RewriteEngine On RewriteRule ^\.html$ /articles/author/persons-name [L]


0

I'm not sure if you've found a solution yet, but I was in the exact same situation as you. I moved a site into a subdomain but still existing in the root directory as per the codex, changed the permalinks, modified the .htaccess file and ran into the same problems. To fix this, I just changed my Site Address URL to match the Wordpress Address URL (the ...


3

You can make use of the Filesystem API, especially the copy_dir() method - source - does seem to be what you are looking for. Take a look at the docblock from the above source link for a little bit more information: /** * Copies a directory from one location to another via the WordPress Filesystem Abstraction. * Assumes that WP_Filesystem() has already been ...



Top 50 recent answers are included