Tag Info

Hot answers tagged

6

To answer the first question... If you look within the WP_Automatic_Updater class found in wp-admin/includes/class-wp-upgrader.php we note the method is_disabled which is used by the method should_update to determine whether or not an automatic update is allowed. The is_disabled method will return true under the following conditions, if ...


5

An alternative is to create a simple Must-use plugin so this doesn't depend on the theme. Create a file wp-content/mu-plugins/disable-auto-update-mail.php <?php /* Plugin Name: Disable Auto Update Mails Plugin URI: http://wordpress.stackexchange.com/questions/157056 Version: 1.0 Author: kraftner AuthorURI: ...


3

First things first, avoid defining functions inside functions. PHP doesn't have a problem with it, but it's usually a sign you're "doing it wrong" and it just leads to unnecessary headaches. Second, your foreach loop at the bottom is a little malformed. You need to define the <ul> outside the loop, and then append to $html - otherwise you just end up ...


2

In WordPress, there are four types of automatic background updates: Core updates Plugin updates Theme updates Translation file updates If you don't like this, then add the constant to deactivate this feature in the wp-config.php, that it works on a default install. Constant to Disable All Updates define( 'AUTOMATIC_UPDATER_DISABLED', TRUE ); Constant ...


2

The "autoupdate" value you see there is just a string in the "response" field from the version check API call. It doesn't determine whether or not your site actually performs an autoupdate. You'll see that field in every response returned from core version checks. Basically, it's just saying that a potential autoupdate is available for download. The ...


1

How to disable core auto updates but enable plugins and themes auto updates If you want to stop the autoupdates of the WordPress core, but to enable them for your Plugins and/or Themes, you can add these lines in the wp-config.php file: Stop the core auto updates: define( 'WP_AUTO_UPDATE_CORE', false ); Then Enable the plugins/themes: ...


1

As it turns out there's a difference between 127.0.0.1 and localhost. Once I change my requests to: http://localhost/white/check-plugins/plugins/test-plugin.zip and a few other instances of the IP version, the update worked like a charm. Stack Overflow has some good answers on why this could be: What is the difference between 127.0.0.1 and localhost?


1

This one is actually surprisingly simple; add this to your wp-config.php file and all automatic updates will be blocked when outside of the specified hours: // Suspend updates when outside of business hours, 9:00 AM to 5:30 PM $updates_suspended = (date('Hi') < 0900 || date('Hi') > 1730); define( 'AUTOMATIC_UPDATER_DISABLED', $updates_suspended ); ...



Only top voted, non community-wiki answers of a minimum length are eligible