Tag Info

Hot answers tagged

7

Survey said! Wolf Fence in Alaska. The basic idea is that you divide your problem space in half by inserting a print "Hi, Mom!\n"; exit; (insert your favorite phrase) somewhere near the "middle" of your code. If you get the message, then the bug is beyond where you put the print, so move it farther along in the execution. If you don't get there, move the ...


6

I use XAMPP myself, but WAMP isn't much different. I'll bet you have not enabled the curl module. WordPress can use other methods (streams and fsockopen) as a fallback, but these may be disabled by default as well in a stock install. Curl is preferred and easy to enable. Close WAMP Go your the \bin\php\version directory in WAMP Edit the php.ini, and ...


5

Souljacker, I would first take a look at your plugins. Star Ratings for Reviews hasn't been updated for over 3 years and looks like its real heavy on the db. I saw some raw sql with some INNER JOINS that look troublesome. On the server side you should implement some object caching. APC is the defacto standard and will give you the best results. Once ...


5

The most common thing to try is a content caching plugin like W3 Total Cache or WP Super Cache. Both will cache entire pages to disk, and will allow the Apache web server to completely bypass PHP processing for many page views. With W3 Total Cache, you can also cache system objects and the results of database queries, as well as using a CDN (Content ...


4

In short yes... 'External' Rewrite Rules If in add_rewrite_rule the rule is isn't directed to index.php then the rule is treated as an 'external' rule (i.e. not to be processed by WordPress' internal handing of rewrites) and instead written to the .htaccess file. I.e. if: add_rewrite_rule('^nutrition/([^/]*)/([^/]*)/?','somethingelse.php?p=12&food=$1 ...


4

You're looking at the problem the wrong way. The error you're seeing isn't an error coming from WordPress, it's a PHP error. Somehow, somewhere, something is limiting the memory limit to 96M, and it ain't WordPress that's doing it. Here's the thing: WordPress can't actually limit the memory on most servers. I know that it attempts to increase the limit ...


4

Just to break cycle of "doesn't belong here". WordPress basically has no specific requirements for web server itself (which doesn't even have to be Apache), aside from permalinks. The message you are getting seems to be performance-related and may or may not be connected to you using WordPress. For starters check if your traffic had recently increased and ...


4

Many of the examples assume you're not the only person running stuff on the server, or that suPHP or some other utility is running to make PHP run as a user other than the web server. With a basic Debian LAMP install, where PHP runs as the www-data user, it's safe and normal to set ownership of everything under the web server document root directory as ...


4

Without looking at your box to see exactly what's going on, here are some potential avenues of slowness: Potential Causes Apache Apache is usually configured in such a way that a single httpd process is always running in the background. When a request comes in over the wire, it spins up a new httpd process to handle the request. Once the request closes, ...


4

Number 1 is not wordPress, but PHP. $_GET['type'] is undefined. Use an isset( $_GET['type'] ) conditional. Number 2 the error message tells you exactly what to do. Instead of calling: add_custom_background(); ...call: add_theme_support( 'custom-background' ); Number 3 the error message tells you exactly what to do. Instead of calling: ...


3

This really isn't a Wordpress issue. That said, the key error is "open_basedir restriction in effect." If you're running your own VPS, you need to learn to configure it. open_basedir restrictions keep scripts in one directory from being able to affect scripts in another directory, which is an important security feature. If one accounts gets hacked, ...


2

Take a look here: Performance tips for a large user base - it's a useful set of things to look at that go beyond just Apache. When looking to optimise performance, it's pretty important to look at the entire infrastructure to see where you might have issues - for example one of of my sites I eventually traced an issue that initially looked like an Apache ...


2

For now, this is unsolvable according to Mark Jaquith, as noted here. Q: Does this support WordPress in multisite mode? A: No. Not until WordPress supports WordPress-in-a-subdirectory installation for multisite. If you're a WordPress hacker who wants to help with that feature, drop me a line


2

You can adapt the site url which is stored in the database based on what domain you are viewing the site from. Add the following to wp-config.php: define( 'WP_HOME', 'http://' . $_SERVER['HTTP_HOST'] . '/yourwebsitename' ); define( 'WP_SITEURL', WP_HOME ); If you use a subdirectory install (ie: you view the site from http://192.168.0.2/yourwebstename but ...


2

Codex has an article on Changing The Site URL, you can edit values in database or override them in config. To have your site work from root you can either relocate WP there altogether or configure it to support root of the site, while still residing in subdirectory. See Giving WordPress Its Own Directory on the latter.


2

Things are working the way they are supposed to, and possibly the only way they can work. Let me explain. Without an Apache module called mod_rewrite (or the equivalent Nginx or IIS component) requests to PHP pages have to go to an actual filesystem file. That is what you see with requests like 192.168.1.8/wordpress/?p=123. The file being accessed is the ...


2

Anchor will setup apache or nginx for me - but which should I choose?! Based on your concerns, I'd recommend Nginx -> Apache stack. Please let me explain. By default, Nginx can only process static content, such as images, CSS and JS files. Nginx passes PHP requests to PHP-FPM or to other servers such as Apache. Nginx can still cache dynamic content ...


2

Both servers are listening to the same port. You have Nginx set to listen to 80 and nothing is set for Apache unless it's in your ports.conf. Your also proxy passing to Apache port 80 in your Nginx conf. In the Nginx conf change proxy_pass http://127.0.0.1:80; to proxy_pass http://127.0.0.1:9000; change listen XXX.XXX.XXX.XXX:80; to listen 80; In ...


2

Depending on your server configuration, you can change the setting for MaxClients in /usr/local/apache/conf/httpd.conf. [edit: Since I've only been given a line or two about it myself from my server admin, here is a better explanation as to what MaxClient is... ServerLimit controls the maximum configured value for MaxClients. Reducing MaxClients on ...


1

You also need to install the domain mapping plugin. http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/ http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/


1

I think it has to do with http://core.trac.wordpress.org/ticket/15044 The problem appears to be localized around the use of ob_get_clean in the definition of apache_mod_loaded in the branch that has to parse phpinfo.


1

Your home page is available on the link in the upper left corner right besides the WordPress logo. Update In your .htaccess or httpd-vhosts.conf you have to declare the index.php as index file, and FollowSymLinks has to be On: # sample .htaccess code Options -Indexes +FollowSymLinks DirectoryIndex index.php index.html


1

The problem is defiantly not with the theme or any specific plugin. The problem is the fatal error thrown anytime an include or require is seen. My only other suggestion is to open your php.ini file and find the line include_path='.:/usr/local/lib/php' and comment it out by placing a ; infront of it so it looks like this: ...


1

Here is how I'd do it: http://wordpress.org/extend/plugins/redirect/ Install above plugin Create a page Add custom field: redirect of a value of http://theprimarkonlineshop.com/category/blog Set page you have created to the sites homepage.


1

you can also try wp_redirect: <?php wp_redirect( 'http://theprimarkonlineshop.com/category/blog/', 301 ); exit; ?> put it in a custom template and set it as your homepage.php file or you can do this from your settings also.


1

Are you sure /wp-includes/load.php made it to the server? If you were installing manually, there's a chance it got lost during the transfer. Happens to me occasionally using FileZilla. The error messages are basically telling you that the server can't find the file, so make sure the file is there.


1

Easiest way: Use mod_suphp instead of mod_php. This should just be a matter of using whatever ubuntu's package manager is to remove mod_php and install mod_suphp instead. mod_suphp is a slightly modified version of mod_php. It does the same thing, but it sets the user of the apache process to be the same as the owner of the PHP files when the PHP executes. ...


1

You can permanently store the FTP credentials in wp-config.php. Add the following to this file: define('FTP_HOST', 'ftp.example.com'); define('FTP_USER', 'user'); define('FTP_PASS', 'password'); define('FTP_CONTENT_DIR', '/home/username/public_html/wp-content/'); define('FTP_PLUGIN_DIR ', '/home/username/public_html/wp-content/plugins/'); This will ...


1

If you are still looking for a solution, your nginx configuration should look like this in order to achieve what you described... server { listen 80; server_name yourdomain.com root /path/to/yourdomain.com; index index.php index.html; location / { # directives to handle static site } location /sub { # directives to handle WordPress ...


1

Basically you have three parameters here: Current server time Schedule start time Schedule end time Then your task boils down to using custom field parameters in query to request posts with two conditions: schedule start hour is smaller than current hour schedule end hour is larger than current hour



Only top voted, non community-wiki answers of a minimum length are eligible