0
votes
0answers
67 views

remove_shortcode('gallery') version 3.8.1 vs 3.6.1

I've developed a plugin for my own needs on version 3.8.1. Fully tested. I've copied the files to version 3.6.1 on my hosting machine, and it doesn't work. The first error I got, was that the class ...
6
votes
5answers
192 views

What is the importance of writing a < WP 3.x compatible plugin nowadays?

I am currently writing a simple-ish plugin with custom posts and a couple functions, using post metadata and adding a couple of variables to the "options" table in the database. During my research, I ...
0
votes
2answers
110 views

What is the Timeline for the Active Version Pie Chart in the Repository?

When going through your own plugin details and checking the active version downloads. It's helpful to see which version that webmasters prefer, but I see no details on the subject on WordPress (and on ...
1
vote
2answers
106 views

Plugin development: How many plugin and WordPress version combinations to support?

I'm developing a plugin (my first plugin), and I wonder how to think about [supporting and testing various plugin version and WordPress version combinations]. For example, if I develop a plugin, and ...
1
vote
1answer
38 views

Is there any way to allow a plugin to write over a previous version?

When installing a plugin, it will not install if the directory to which it is attempting to install already exists. This means that users of our plugin must first manually deactivate and delete the ...
12
votes
4answers
331 views

Automatically determine minimum WordPress version required for a plugin?

When developing a plugin, is there a way to automatically determine the minimum version of WordPress that's required to run it? I want to make sure that the Requires header is accurate, but manually ...
0
votes
1answer
147 views

Wordpress 2.8 Widget API is suitable for Worpress 3.1.4 plugins development?

I am a little confused, the Wordpress 2.8 Widget API reffers to WordPress version 2.8 or is refferred to API version? Should I use 2.8 Widget API for writing my WordPress 3.1.4 widget?
6
votes
4answers
130 views

Is it necessary to bump a plug-in's version if you're just updating the “Tested up to” attribute?

I've got a number of plug-in's hosted on the wordpress.org svn server ... with the immenent release of 3.1, I would like to update the "Tested up to" meta data. There will be no functional changes to ...