1
vote
1answer
50 views

Custom query AFTER rss fetch_feed not working

I'm trying to do a custom query after an rss fetch_feed but for some reason nothing shows up. The code I'm using to fetch the feed is: <?php // Get RSS Feed(s) include_once( ABSPATH . WPINC ...
2
votes
1answer
451 views

fetch_feed: retrieve entries in the appearing order, not chronologically

I'm using WP function fetch_feed to retrieve a feed and display its items. <?php /* include the required file */ include_once(ABSPATH . WPINC . '/feed.php'); /* specify the source ...
1
vote
1answer
485 views

combine multiple feeds with fetch_feed and display blog titles for each item?

I'm trying to display multiple feeds using the fetch_feed function. Its working well thus far except I can't figure out why the title for each individual rss feed will not show up. Here is my code: ...
0
votes
3answers
395 views

Unable to display favicon using get_favicon()?

I'm using fetch_feed (based on Simplepie) to display an array of RSS feeds (favicon & headlines only). Documentation on the simplepie website says to use get_favicon in the stylesheet. And I'm ...
0
votes
3answers
408 views

Passing feed URLs with “&” to fetch_feed()?

How do I pass feed URLs with & in the URL to fetch_feed()? The feed is not parsed correctly if there is a & in the feed URL. Actually it works in the example I gave, but now I'm populating ...
2
votes
1answer
1k views

Troubleshooting fetch_feed and SimplePie

I've got a very basic solution using fetch_feed() and SimplePie to pull in RSS items which is working on my localhost, but for some reason is_wp_error() persists as true on the live server. Is there ...
1
vote
2answers
591 views

How to set the cache for the built-in SimplePie feed parser?

I'm using the built-in SimplePie, AKA fetch_feed(), to retrieve a feed, and I want to be able to adjust the cache time from an admin menu. SimplePie itself is well documented, but not so much the ...