The tag has no wiki summary.

learn more… | top users | synonyms

0
votes
1answer
114 views

Strange characters - despite everything being UTF-8

Not sure why this thread was closed, but this is the same issue inflicting many people. All my WP config settings are in order: //define('DB_CHARSET', 'utf8'); //define('DB_CHARSET', ...
0
votes
1answer
33 views

wp-login.php ampersand in url results in 404

I've got this problem where the wordpress site will throw up a 404 if the wp-login.php has an ampersand appended after it (e.g. session expired argument). I've changed themes, disabled all plugins, ...
0
votes
1answer
46 views

Non english charcters support for WP Customer Reviews

I've been looking all over for a fix for WP Customer Reviews. It is showing question marks on submitted reviews when entering none English characters. The translation it self is quite trivial, You ...
0
votes
1answer
80 views

Wordpress Dashboard Characters Messed Up

I recently added a new post, and afterwards, many of the text lines on the wordpress dashboard appear messed up, almost as if they are protecting from a security breach or something. I have tried ...
0
votes
1answer
100 views

Language selection for blog doesn't exist?

I've been installing and developing on Wordpress for a while with a focus on sites in Hebrew. Recently I moved a site from a multi-site installation I have for development to it's own hosting and ...
1
vote
0answers
17 views

esc_js() breaks unicode sequences by removing the slash '\' character

I've noticed that esc_js() is breaking unicode encoded characters by removing the '\' (slash) character. For example: esc_js('\u041f') returns: 'u041f' I can potentially use REGEX to identify ...
1
vote
0answers
113 views

Symbols such as £ end up being  in the database

Any posts with symbols such as £ or & or ♥ end up being  or worse. It doesn't show in the admin panel on the edit post page, but it is saved in the database as  and shows on the actual live blog ...
0
votes
0answers
25 views

Wordpress site stopped working after simply opening header.php in the wp-admin editor

I opened header.php inside the wp-admin editor and suddenly the actual site is filled with diamond shaped question marks. Admin area still works. The weird thing is that I didn't even perform any ...
0
votes
0answers
57 views

Special characters showing in fallback font

I have created a widget that displays some text using a custom font imported with CSS @font-face. The font have support for scandinavian characters åäö, but when I display these characters in my ...
0
votes
0answers
23 views

Database Encoding and Editor Issue

I can't figure out what's going on. On a dev site, a whole bunch of question marks are showing up: [http://192.185.118.90/~saintros/school/about/meet-faculty-staff/]. Also, when I go in to edit that ...
0
votes
0answers
239 views

Shortcodes in widget titles: attributes include quotes which are html encoded, why?

I wrote a shortcode plugin that works with widget titles. So I added shortcode support to widget titles like this: add_filter('widget_title', 'do_shortcode'); So my shortcode looks like this: ...
0
votes
0answers
99 views

Percent-encoded slug appears as decoded

What is the WordPress mechanism for creating post slugs when creating a new draft? I enter a post title, and after some seconds, a suggested permalink appears. I have traced this behaviour to the ...
0
votes
0answers
48 views

Post removes any text from post that's following special characters

I have a weird problem with losing content in posts with special characters in it. Let's say I inserted the following content into a post: Hello, 👿 This is my post Wordpress would ...
0
votes
0answers
197 views

wp_insert_post and title not utf8 inserts with empty title?

I'm using wp_insert_post I loop over a text file one row at a time and for each row I create a post. The text is set as the `post_title', for text that is not utf8 the post inserts but with an empty ...