The tag has no wiki summary.

learn more… | top users | synonyms (1)

0
votes
1answer
309 views

How to find out which function is causing a 404

So I am trying to upgrade a WordPress project and for one section I get the 404 instead of seeing a product page. I looked around and tried adding this to my functions.php add_action('wp_head', ...
0
votes
1answer
39 views

Best place to call xdebug helper functions?

Right now I place the following code wherever I expect something to go wrong. /** xdebug helper */ error_reporting(E_ERROR); ini_set("display_errors", 1); ini_set("html_errors", 1); ...
0
votes
1answer
139 views

Cannot Modify Header Information - While trying logging in

I am having the same issue as cited on: Cannot modify header information - headers already sent (Theme Specific : functions.php) Can you give me a help on that. I am using Optimize Press Theme This ...
0
votes
2answers
114 views

Wordpress + Buddpyress - troubleshooting server overloading

I have a Wordpress+Buddypress installation which is regularly going down - the number of HTTPD on the server and the server CPU load both peak suddenly and the server fails to recover. A restart of ...
0
votes
1answer
861 views

Weird undefined index: id,std notices. How to fix it?

Ok I'm running my wordpress in debug mode. I'm getting lot of notices. This is my code. <?php //allows the theme to get info from the theme options page global $options; foreach ($options as ...
0
votes
1answer
416 views

Fix warning: Missing argument

i want to submit a theme to the wordpress.org. when i put the define('WP_DEBUG', true); in my wp-config.php. my theme showed some errors.but i don't know how to correct theme. Q1:Warning: Missing ...
0
votes
1answer
340 views

my blog crashes ie7?

hey guys, weird problem. My blog theme works fine in ie8, ie9 and all other major browsers... however ie7 doesn't even render it? in ie7 it seems like my blog even has serverside problems? any idea ...
0
votes
3answers
542 views

page template - undefined structure in source code

hey, i have the following page template for a sitemap. <?php /** * Template Name: Sitemap */ ?> <?php if (have_posts()) : while (have_posts()) : the_post(); ?> <div> ...
0
votes
3answers
8k views

Get PHP Fatal error on globalized $wpdb: Call to a member function insert() on a non-object- I have no clue. What to do?

I am trying to utilize this function. I cannot figure out why I am still getting the PHP error. All I can figure out is that for some reason the template isn't able to access $wpdb. I don't know ...
0
votes
2answers
171 views

Is there ANYTHING about this query that's incompatible with WordPress 2.9.2?

I've been puzzling over this one for two days. Still can't figure it out. I'm testing a theme release in multiple versions of WordPress using xampplite on localhost on a PC. I'm having a problem on ...
0
votes
2answers
74 views

Why is adoptStyles-css stylesheet link added to every page?

By looking at the source of any of the WordPress pages on my site, I can see there is this stylesheet link: <link rel='stylesheet' id='adoptStyles-css' ...
0
votes
0answers
15 views

Formatting wordpress debug messages

On my local PC (win 8 & IIS) when I get a wordpress debug message I get a nicely formatted table at the top of the page with a full stack trace. When I enable debugging on my linux hosting I just ...
0
votes
1answer
15 views

Method 'post_title' not found in class.

I'm running some code through phpStorm and am getting an error: Method 'post_title' not found in class. at this line: echo $post->post_title(); Is that phpStorm getting things wrong or am I ...
0
votes
0answers
23 views

34 Plugins Present In /wp-content/plugins Directory But Only 6 Of Them Are Being Displayed In WP Admin -> Plugins

There are around 34 plugins present in the /wp-content/plugins directory but only 6 of them are being displayed in the wp admin -> plugins section. Why other plugins are not being displayed. Another ...
0
votes
0answers
52 views

How can I debug the TTFB in WP?

I'm developing a WP theme, based on _s default theme with WP 4.1.1. I keep getting a TTFB(time to first byte) of 22s, consistently both on the front and back of the site, while on localhost. Here's a ...
0
votes
1answer
17 views

Plugins effecting layout & login

I've been working on this issue by myself for a week, and I feel like I'm at my wit's end. Need some advice on what to try next. The issue is that my site has the white screen of death (no login) ...
0
votes
2answers
60 views

Using $post->post_name in body id causing error: Trying to get property of non-object

I'm getting the following error in my debug.log: PHP Notice: Trying to get property of non-object in /my-wesbite/wp-content/themes/express/header.php on line 36 This is line 36 of header.php in my ...
0
votes
1answer
192 views

wp_enqueue_script was called incorrectly… i want to work with debug on

i know that this error is just a notice: notice: wp_enqueue_script was called incorrectly. scripts and styles should not be registered or enqueued until the wp_enqueue_scripts, admin_enqueue_scripts, ...
0
votes
1answer
81 views

wp-includes/comment-template.php:26 - Trying to get property of non-object

I get this notice when debugging my new site. Does anybody know what this means? It doesn't break the site but it's just a warning when I switch debug mode on and I would like to solve this issue. ...
0
votes
0answers
24 views

How to find which plugin crashes

I use wordpress version 3.8.3 and as many times as i tried to update wp the site crashes. Probably it's due to plugins. Am trying to find a way to learn which plugin causes this confliction but i ...
0
votes
2answers
41 views

How to see list of plugins

Is there any tool out there for seeing a list of all the loaded plugins and how much time they took to load? Looking to analyze plugins effect on my site's performance.
0
votes
1answer
20 views

How can I turn off WP_DEBUG_LOG messages coming from a specific plugin or theme?

This is a seemingly simple question... I was wondering if anyone knows how to turn off WP_DEBUG_LOG messages coming from a specific plugin or theme? This assumes define('WP_DEBUG_LOG', true); in ...
0
votes
1answer
30 views

Debugging WordPress

Looking for advice on debugging sql queries. I find that plugins and themes are causing heavy queries and slowing performance. Any easy ways for doing this? Tools? Shortcuts? Thanks! Daniel
0
votes
1answer
64 views

Blank sign in page

I have a serious problem with my wordpress site. When I try to enter into my wp-admin page, I get blank page. I tried every solution possible including: deactivate plugins, update to higher wordpress ...
0
votes
0answers
18 views

Unable to find BP_Group_Extention

When I try to extend Buddypress' groups, I get false from the function-call class_exists( 'BP_Group_Extension' ). The function is called during my plugin initiation, and I am able to do other ...
0
votes
0answers
21 views

Debugging Missing Elements in Taxonomy

I'm trying to debug an issue and I was hoping I could get some direction. With the same exact taxonomy page template, one of the pages is missing the sidebar and the WP admin bar (logged in), while ...
0
votes
1answer
31 views

Theme parts path location dump

Few months back I was working on customizing theme that I was assigned to. I remember that I used some function or define something in the config or theme functions file and than it displayed debug ...
0
votes
0answers
165 views

Preview with Custom Post Type Not Working

At this point I have tried everything I know to fix the issue. Issue: preview only works right after a custom posts is loaded or updated. If you make any changes or hit preview twice without updating ...
0
votes
1answer
72 views

loging to Admin page not working at all

I'm trying to log-in to the admin page of my website without any luck, only i got white page, hers what i did to identify the problem: I have enabled the Debugging in wp-config.php // Enable ...
0
votes
1answer
68 views

How do I set up Debugging?

In my wp-config.php, I have: // Enable WP_DEBUG mode define('WP_DEBUG', true); // Enable Debug logging to the /wp-content/debug.log file define('WP_DEBUG_LOG', true); // Disable display of errors ...
0
votes
1answer
56 views

Disable Debug Log Programmatically

I'm trying to disable WP_DEBUG_LOG if and only if debug.log exists. I'd like to hook into wp_footer and test if the file exists and if so disable my debug log. All I've found though is that ...
0
votes
1answer
64 views

Changes to WordPress database using phpMyAdmin not reflected on blog

I am updating my database using the phpMyAdmin UI and the changes are not reflected on the WordPress blog. The reason for doing this is when some changes were made recently to the blog the site hanged ...
0
votes
0answers
54 views

Wordpress plugin admin page breaking

I am developing one file uploading plugin for my wordpress site to upload posts along with taxonomy and post meta data. Functionality wise it is working fine but when file uploading is finishing ...
0
votes
1answer
206 views

Accessing Variables Used In a Plugin Using PHPStorm + XDebug

I'm currently attempting to use XDebug 2.2.1 and PHPStorm 7.1 to debug my WordPress plugin. So far, I've successfully installed XDebug and breakpoints are working fine. However, I'm unable to access ...
0
votes
0answers
90 views

How can I get a traceback on function calls?

I've been trying to make a search page, but I keep getting redirected back to the main site. I can't find anything useful in the log about why this might be happening. Is there a way I can enable some ...
0
votes
0answers
57 views

Strange behaviour using 3.8.1

I have upgraded some of my blogs into 3.8.1 and I am experiencing a strange behaviour. I have created in the past two types of themes that use mostly the same mechanism, assigning page templates. The ...
0
votes
1answer
89 views

Fatal error after changes to functions.php, even with original file

Getting Fatal Error: Cannot redeclare theme_feature_setup() message after code changing in the functions.php file. I've tried deleting functions.php file and uploading the previous version but I still ...
0
votes
0answers
41 views

WP Debug set to true but still wsod

I'm trying to do my first wordpress plugin, and I've added this on my wp-config.php define('WP_DEBUG', true); define('WP_DEBUG_LOG', true); define('WP_DEBUG_DISPLAY', false); but i still have ...
0
votes
1answer
30 views

What tool are available in the wordpress API for debugging a plugin?

I am very new to plugin development. I have created my first plugin but when I activated it, it caused the majority of every page on the site to stop being generated. I have echoed something from ...
0
votes
0answers
21 views

Queries gone haywire since update to 3.8.1 [duplicate]

I have a WordPress install on a dedicated server with decent memory (upwards of 8GB) Since upgrading to 3.8, I started getting mysql disconnects/timeouts, better known as MySQL server has gone ...
0
votes
0answers
139 views

Console shows ReferenceError: jQuery is not defined, no clue why!

I just installed FirePHP to help with debugging in WP, but for some reason all it shows is ReferenceError: jQuery is not defined. I have some jquery stuff on the page that seems to be working just ...
0
votes
2answers
38 views

Debug Performance Issues

I've had a WordPress blog I've hosted on Dream Host for several years now. Recently (the past year) my site is going down often. Via Dream Host I found that I'm using up my CPU limit and they are ...
0
votes
1answer
134 views

TGM plugin error in Theme Check Plugin

Errors generated by theme-check plugin and with the code REQUIRED: plugin-activation.php. Themes should use add_theme_page() for adding admin pages. Line 335: add_submenu_page( add_submenu_page( ...
0
votes
2answers
25 views

How do you get the docroot directory?

I'm trying to include a file in the docroot when I'm in the admin area. (Yes, I know this is bad form: I'm only doing it for debugging purposes.) How do I get the fully qualified docroot directory?
0
votes
2answers
81 views

Some ways to debug code

I have a BuddyPress installation with many custom code. I had everything ready for production until I moved my database to shared hosting. The problem is that in strange ocasions, all the activities ...
0
votes
0answers
34 views

admin.php taking 14 seconds

This is a clean install but it has a (relatively) huge database of dummy posts/comments/etc. But even on single-post loads it still takes just as much. Narrowing further down menu.php takes 8 ...
0
votes
3answers
758 views

Not sure how to debug: Send specific users an email when posts are published

I've got the following code, which is supposed to run when a new post is published for the first time, check if a custom field 'specific_users' has data (this uses Advanced Custom Fields), and if so, ...
0
votes
0answers
68 views

WordPress won't display errors at all

I have been having constant issue with WordPress not displaying errors at all and I have no clue what is wrong. PHP errors display on non-wordpress related pages. Debugging is turned on. Display ...
0
votes
1answer
593 views

Certain aspects of site suddenly not working in Chrome and Firefox

My site has been working perfectly in all browsers, until suddenly 2 days ago. Now in Chrome and Firefox, the main page accordion slider is stuck, the "log in" button is not functional, and a few ...
0
votes
1answer
204 views

How to solve the fopen error?

I recently updated xampp to 1.8 and enabled xdebug. I'm not sure if this is the reason for this error message which I didn't see before: Warning: fopen(http://api.wordpress.org/plugins/info/1.0/): in ...