The tag has no usage guidance.

learn more… | top users | synonyms

0
votes
4answers
9k views

WP_Query and using a variable for 'cat'=> in the args array = WP Bug?

For the sake of this discussion, here's a version of my query within category.php: wp_reset_query(); $category_id = get_cat_ID(single_cat_title('', false)); $my_query = new WP_Query(array( ...
-2
votes
2answers
130 views

Is this a WordPress security bug?

<?php if ( ! is_admin() ) return; echo 'You should not see this if you\'re not logged in!'; ?> If you put this in a mu-plugin, and go to your admin, e.g., example.com/wp-admin/ while you are ...
0
votes
1answer
142 views

why i cannot see some plugins while they are enabled on network admin page?

i am using WPMU 3.3.1, i have some plugins enabled but why i cannot see them in some wordpress panel, it is confusing, but these plugins may take effect to these blogs, it is really strange to take ...
0
votes
1answer
303 views

Is this a wordpress bug? get_comment_link auto shoots when user visits his dashboard

If user is editor, this function auto-shoots when user visits his dashboard! How is this possible? This function should only work when user successfully posts comment, so what is happening? could be ...
2
votes
1answer
140 views

Bug in Stackoverflow styled badge system script

I have modified an old Stackoverflow inspired badge system script to work with the latest Wordpress version. You can view the code here (and please feel free to use it if you wish): ...
2
votes
1answer
891 views

Programmatically insert hierarchical terms & set terms for post causes glitch? [duplicate]

I am inserting an array of terms into my custom taxonomy programmatically. Some terms have parents/children. After each term has been entered, I then insert an array of posts into my custom post type. ...
0
votes
1answer
110 views

Photos automatically uploaded to Media Library

Here's a bizarre one for you guys. I was using Search RegEx to remove Blogger html formatting that was screwing up my imported posts. Images hadn't been imported, so they were loading from Blogger ...
3
votes
3answers
2k views

Dashboard says “no posts found” even though there are some posts

I have a weird bug on the dashboard: the dashboard says there are a total of 3 posts, but the list is empty and says "No posts found" (see image below) It's a fresh install on a shared Windows ...
11
votes
5answers
4k views

after_setup_theme always runs

I am setting up a child theme for some of my faculty members, and as a part of the theme, I would like a handful of plugins to be activated at the time that the theme is activated. So, naturally, I ...
5
votes
1answer
626 views

Weird behaviour when adding terms/term_taxonomies programmatically

This certainly looks like a bug to me. I put together the following code for you to test it on a fresh install. Basically, the code will add two sub categories under the "uncategorized" to achieve ...
1
vote
1answer
43 views

Plugins Page invisible / white

I found a lot of posts about the white-screen-of-death, but as far as I can tell, that's not my problem. Whenever I open the backend, everything is fine until I enter the plugins section. The ...
0
votes
1answer
381 views

Best Browser for Editing Posts

What browser is best supported by Wordpress.org for editing posts in the visual editor (which I guess is TinyMCE)? I use Google Chrome and have run into issues which are specific to just this ...
0
votes
1answer
1k views

get_shortcode_regex() only matches first shortcode

The Codex has an example of using get_shortcode_regex() to check if a shortcode is being called on a given page: $pattern = get_shortcode_regex(); preg_match('/'.$pattern.'/s', ...
0
votes
2answers
1k views

Problem saving wordpress settings with current version. Is it a bug?

With the current version of wordpress 3.2.1 I am having this kinds of problem. I install wordpress frequently and I did not notice it before 3.2.1 Problem: Not being able to save settings under ...
1
vote
1answer
863 views

Password Protected page not asking for a password

I have set a page to be password protected in the admin, but for some reason WP is not asking for the password when viewing the page. It definitely isn't a plugin as I have confirmed the behaviour ...