Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've been searching the web and in this great forum but I didn't find anything.

I got some issue with a code higlighter plugin. Everything is fine except that some php tags do not work properly :

<!--?php instead of <?php

It just breaks markup ! I only use HTML Editor.

How can I manage to make it work?

EDIT: in the meantime I just changed plugin and it works fine but I'm curious to know how to solve this issue. The plugin is Google Syntax Highlighter (verry old I know)

share|improve this question
2  
What's the plugin? What have you tried? –  Pat J May 19 '13 at 14:29
1  
At the very least, add a link to the particular plugin you are using. –  s_ha_dum May 19 '13 at 14:59
    
sorry I missed that-> I edit –  JMau May 19 '13 at 15:03
    
Are you sure the plugin is breaking the tag and not WordPress formatting function? –  s_ha_dum May 19 '13 at 18:26
    
I do not really know, I use some remove_filter() to prevent WP from formatting content. Besides the plugin uses exclusively javaScript to render code, I was expecting some htmlspecialchars() and/or str_replace(). I'm not saying it's better but I do not want content display to depend on js. –  JMau May 19 '13 at 21:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.