Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm using the following code:

$paged = (get_query_var('paged')) ? get_query_var('paged') : 1;
query_posts('posts_per_page=3&&paged='.$paged);

and then

global $wp_query;

$big = 999999999; // need an unlikely integer

echo paginate_links( array(
    'base' => str_replace( $big, '%#%', esc_url( get_pagenum_link( $big ) ) ),
    'format' => '?paged=%#%',
    'current' => max( 1, get_query_var('paged') ),
    'total' => $wp_query->max_num_pages
) );

As per wordpress codex - which works fine except on page 2 onwards the title in the browser says "Page Not Found | Blog" which is odd, because it is there, and everything else works fine!

The posts display as they should, all the post titles display and link through to the correct posts.

It's not a major problem, because it's working. But I just wondered if anyone knew why this was happening. Pagination always seems to throw me off anyway...

share|improve this question
    
If you'd like to see the site for yourself it's here: creativecollective.biz/blog –  Dave May 14 '13 at 11:57
    
I don't see any "Page Not Found" message. –  s_ha_dum May 14 '13 at 13:05
    
read this and then read this. –  Milo May 14 '13 at 13:08
    
Thanks @Milo - this also caused a problem with the categories displaying, so rewriting the loop fixed that too. Thanks for the help! –  Dave May 14 '13 at 13:29
    
Hi, I have the exact same problem. Can you please share the solution? Thanks. –  Devner Jun 15 '13 at 12:38
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.