Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am having the Famous has failed to upload due to an error Unable to create directory error that soo many people run into.

Any search on Google of StackExchange will result is the common, change your file/folder permissions answer.

Well I am running WordPress vs 3.5.1 on Windows 7. Permissions aren't as simple as setting chmod 777 on Windows. I have check and even tried resetting the File permissions on Windows which from what I can tell is basically setting a user as the owner.

Has anyone who has had this problem on Windows actually ever fixed it? All my searches never resulted in an answer for a Non- Linux or Mac

enter image description here

enter image description here

share|improve this question
    
Please add details what web server are you using and how is it run. –  Rarst May 12 '13 at 13:51
    
@Rarst I am running Apache on XAMPP. S I have mthis particular site mapped to http://domain.dev instead of localhost/domain and I just noticed my other WP installs that are accessed through Localhost URL instead of a Virtualhost, those one allow Upload without a problem –  jasondavis May 12 '13 at 13:55
    
@Rarst ahhh I spoke too soon, I just installed the same site into my localhost and it still doesnt allow uploads. What is strange to me is I have hundreds of wordpress sites running on my computer for development and only a couple of them behave with this upload error. Worth Mentioning both the newer Uploader and the older one don't work –  jasondavis May 12 '13 at 14:14

1 Answer 1

After trying many things with permissions, I found my problem.

I uses a plugin called Duplicator to move WordPress installs around from server to server, it handles changing URLS's and Paths.

So in settings => Media => Store uploads in this folder it was setting the Full Filepath to my Uploads folder. I changed it to be relative wp-content/uploads instead of full like this E:/Server/htdocs/projects/sitename/www/wp-content/uploads and the problem went away!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.