Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to insert shortcodes into menu links (as I need to display a latest post link). I've figured out how to get the do_shortcode part done.
However, when I insert a shortcode as the menu link [latest_posts var="val"], it immediately gets formatted like so http:(forward-slash forward-slash)latest_postsvar=val. I'm using 3.5.1, and I was wondering what is the filter/action I can use to disable this.

share|improve this question

1 Answer 1

I haven't tested it but most of the time, a good way to disable shortcode, e.g in posts is to double [ like this :

[[shortcode]]

Hopefully this will work in this context.

share|improve this answer
    
Just tried it, still end up like the formatted string :( –  Angela May 10 '13 at 12:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.