Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Running wp 3.5.1.

I have 2 plugins that work in part. They do everything nice. If I click to send emails, they send the emails. However the scheduled emails are not being sent.

The plugins are:

  • Wordpress file monitor plus version 2.2
  • WP-db manager version 2.63

TROUBLESHOOTING I have tried to change the schedule to run every hour, every day, every 2 days. But none of them sends emails, but all the rest is done. WP-db manager generates the backups at the right time. Wordpress file monitor plus checks the files when it should. But after generating the backups or checking file changes, those plugins should send the email with the results.

These plugins have the manual option like "send backup manually to the email" or send the file changes report manually. When I chose to do so, the emails arrive immediately.

=================

I thought that there is some incompatible plugin: I have moved all the plugins but wp-dbmanager to another folder, so that wp-dbmanager is the only active one. Still didn't work. I have tried to change the theme. Still nothing

=================

New installation: I have tried to create a new wordpress installation and new DB in the same server. I have copied all the plugins of the old installation to the new test installation. I have also put the same theme. It works - but it's a test installation :(

=================

How can I troubleshoot this problem? Why the production installation does not send emails when they are scheduled via CRON? Please note that the CRON works, I have installed WP-Crontrol and I can run scheduled jobs manually whenever I want, but still, the cron job works, but it does everything, but sending emails.

P.s. nothing in the wp-debug.

Please help

share|improve this question
    
Where are the emails supposed to go? To the registered admin email? –  vancoder May 8 '13 at 16:42
    
Hi. The emails should go to the mail address I provide. Those plugins have a field where I can type the mail address to send the data to. I have tried different mail addresses, but it behaves the same. I can add that there is nothing in the mail server log as well. The script doesn't even try to send emails, because there is nothing in the mail server logs. –  utnalove May 9 '13 at 6:59

1 Answer 1

This should be a comment, but I don't have comment privelages :(

I had this exact problem not long ago, and felt stupid when I realised it was because I had set a password on the directory...

share|improve this answer
1  
This looks like it might be an answer if the details were filled in. –  s_ha_dum Jun 9 '13 at 13:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.