Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I've been running a WordPress blog for over half a year with no problems [so the hosting should be compatible] and now wanted to install a Network so I could have more than one blog. The least-buggy state I have achieved was:

  • The primary blog worked OK
  • Any secondary blog I made only displayed unformatted text [i.e. ignored any themes]
  • When I tried to reach the administration section of the secondary blog, I have received a 310 error [Too many redirects].

I have been looking around for answers and tried different things, assuming I did something wrong during the installation process. I've tried:

  • Installing the newest WordPress [3.5.1] fresh, multiple times - directly into my www root, as well as into a subfolder [which I then configured according to this which seemed to work fine.]
  • Proceeding to install and configure a Network [according to this]. I used the 'subfolder' type. [Each blog goes into a separate path, not a separate subdomain.]
  • After verifying that the primary blog works, I created a new one.

Update: Before starting the Network installation process I've been warned by the installer that I should perhaps change my Home and Site url so that it doesn't include 'www' [i.e. changing http://www.example.com to http://example.com]. When I tried doing that in the General Settings page, any request to the blog resulted in a 310 redirect error. I haven't been able to make it work. [When I ignored this warning and left the 'www' in place, the Network installation reported no problems.]
I have contacted my hosting provider; the 'www' redirection was their feature and I had it turned off. This didn't solve any of the problems, though.

I'm running out of ideas. What am I doing wrong?

share|improve this question
    
Also one time when I installed the WP in a subfolder, any Network administration page has shown the primary blog's 404 page in the frame where the settings should have been. :/ –  ver May 7 '13 at 7:21
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.