Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have recently moved server and upgraded my wordpress install to the latest version.

Now if I try to access /feed, I get a 404. It used to work. /?feed=atom works correctly.

Thanks.

UPDATE: I fixed it. Virtual host definition had AllowOverrides turned off, so .htaccess was not being picked up. Thanks all for the comments.

share|improve this question
    
Do your other pretty permalinks work? –  John P Bloch Feb 18 '11 at 11:54
1  
Is your .htaccess writable? –  Kaaviar Feb 18 '11 at 11:56
    
Please put your solution in answer to the question. It is ok to answer your own question because it is more clear for those who might encounter this issue and question in the future. –  Rarst Feb 19 '11 at 13:07

2 Answers 2

Possible solutions:

  1. Delete your existing .htaccess, and re-enable the permalinks.
  2. Like Kaaviar said, check if .htaccess is writeable, else, you may have to create it on your own.

Traps:

  1. Does your new server have .htaccess and mod_rewrite enabled?
share|improve this answer
up vote 1 down vote accepted

Wordpress writes url rewriting rules to the .htaccess file, but apache will only use the .htaccess file if AllowOverrides is allowed for the directory where the .htaccess is located.

I enabled it by setting AllowOverride All in the virtualhost configuration, and my permalinks are now working again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.