Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I know this looks like a common question, and I assure you I've tried a bunch of responses, but none seem to work in my case. I'm a Wordpress noob so I might be making some basic error which I can't spot.

I will link you to the actual pages in question so you can see what's going on easily.

The main domain is: visit-ceed.net

We created an add-on domain called reprezentacija.me which can be accessed as a subdomain of the main domain here: http://visit-ceed.net/reprezentacije/.

Opening reprezentacija.me works fine, but all the links still point to the subdomain. How do I get the links to point to the add-on domain? So, instead of pointing to http://visit-ceed.net/reprezentacije/category/novosti/fudbal/ the corresponding link should go to http://reprezentacija.me/category/novosti/fudbal/. Here is the htaccess file in the reprezentacije/ directory:

# BEGIN WordPress
<IfModule mod_rewrite.c>
Options +FollowSymLinks
Options -Multiviews
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d

</IfModule>

# END WordPress
share|improve this question

migrated from stackoverflow.com Apr 19 '13 at 14:38

This question came from our site for professional and enthusiast programmers.

1  
I believe this is not an Htaccess problem, did you changed your blogurl and home url in the options at the admin panel (general) ? also, usually when doing a redirect (if that is what you mean by Add-on domain? ) you usually have an option to leave the original URL or use the new one on all pages (depending on your host ) –  Obmerk Kronen Apr 18 '13 at 16:40
    
Obmerk Kronen is correct. Apache's mod_rewrite module cannot alter the links on your pages, it can only redirect the request once the user clicks or types a URL. If you need to change the way links appear on a page then you need to edit the page. –  Arkanon Apr 18 '13 at 18:30
    
Dump your entire wordpress database into a .sql file - open it up and do a search and replace over the entire document changing the old url to the new url. Update database with new data. –  Richard Denton Apr 19 '13 at 5:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.