Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a custom field [address] that converts a street address and displays it on a google map on the front end post.

Upon manual post update, the latitude and longitude address co-ordinates populate correctly into the [address] custom field and hey presto, the Google Map shows up on the front end post.

The problem I have is this:

The [address] custom field is being populated by an import script (wp-allimport) which updates my posts via daily cron, from a master file.

The cron import update works fine for all post details (e.g. date, images etc), except for the [address] custom field. It does populate the [address] custom field correctly, but the Google Map does not show on the front end.

I believe this is because the post needs to be updated a second time in order for the latitude and longitude co-ordinates to "stick".

How can I rectify this? I have several thousand posts that are updated daily, so doing it manually is not an option!

Things I've tried: I also read these related posts but didn't see anything conclusive. Automate post update for all posts? (I tried Bainternet's suggested code, which simply outputted the custom field data, but but not as the geo-coded map)

http://stackoverflow.com/questions/2297486/render-google-map-in-wordpress-based-on-address-custom-field?rq=1

share|improve this question
    
Does your site use any kind of caching? –  s_ha_dum Apr 18 '13 at 13:10
    
no, i'm not using any special cache control. –  Sol Apr 18 '13 at 21:21

1 Answer 1

I eventually solved this by re-installing WP. It seems there was some kind of corruption which was resolved after a fresh install.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.