Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

So I used the codes below in the functions.php

add_theme_support( 'post-thumbnails', array( 'post'));
set_post_thumbnail_size(100, 75);

And then in THE LOOP I called:

<?php the_post_thumbnail(); ?>

The image has an entry in the database with its url but the file isn't uploaded when I checked in the wp-content/uploads/ directory.

What am I doing wrong?

share|improve this question
    
are you adding the image from the featured image in the post edit screen? does the image show in the post edit screen? What does your page source show? what is the process that you are taking to add the image? –  Jamie Apr 17 '13 at 12:50
    
Hi @Jamie! are you adding the image from the featured image in the post edit screen? -- Yes does the image show in the post edit screen? -- It doesn't show up there already. Just the icon of a broken link of pic. what is the process that you are taking to add the image? --- I use featured image on the right side and then upload pic and use as featured image. File is not uploaded to uploads dir Post/pic has entry to database. –  Pi Lover Apr 17 '13 at 14:23
    
Can you see the image in the media gallery? Has the full-size image been uploaded? –  Pat J Apr 18 '13 at 12:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.