Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm trying to install wordpress in a Cloud Server with rackspace.

But my lack of knowledge in server configuration (LAMP , etc) is making me do a lot of miss configurations .

First I think the .httaccess is not allow. Second the update Wordpress and plugins featured is not allow Third may be more numbers...

let me show my virtualhost file:

    <VirtualHost *:80>
  # Admin email, Server Name (domain name) and any aliases
  ServerAdmin adrian@my.com
  ServerName  my.com
  ServerAlias www.my.com


  # Index file and Document Root (where the public files are located)
  DirectoryIndex index.html, index.php
  DocumentRoot /home/devdreams/domains/my.com/public


  # Custom log file locations
  LogLevel warn
  ErrorLog  /home/devdreams/domains/my.com/log/error.log
  CustomLog /home/devdreams/domains/my.com/log/access.log combined

    <Directory />
      Options FollowSymLinks
      AllowOverride All
      Order deny,allow
      Deny from all
      Satisfy all
    </Directory>

  AccessFileName .htaccess


    <Directory /home/devdreams/domains/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>


    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
        AllowOverride None
        Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
        Order allow,deny
        Allow from all
    </Directory>

    Alias /doc/ "/usr/share/doc/"

    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

    LoadModule rewrite_module modules/mod_rewrite.so


</VirtualHost>

Could somebody help me configure my VH for a wordpress environment

thaaks

share|improve this question
    
.htaccess files won't work with AllowOverride None set. Try AllowOverride All in your /home/devdreams/domains/ section. See smartwebdeveloper.com/apache/htaccess-problems for more info. –  Pat J Apr 12 '13 at 21:03
2  
This seems more like an Apache issue rather than WordPress and such it is probably better asked at ServerFault. –  Joseph Apr 12 '13 at 22:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.