Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a problem with WordPress articles feed. I have discover it analyzing what googlebot is scanning on my site and I disconvered that it is scanning only the feed and not the articles...

So I have try to open feeds URL scanned by Googlebot and I have found a bad surprise...if I try to open these links go into error...all times...

For example you can try to open this link and say the error: http://www.scorejava.com/2013/04/09/27-aspect-orienting-programming-aop-in-spring/feed/

That in english sound like: XML Parsing Error: XML or text declaration not at start of entity

I think that it is creating me big indexing problem !!!

Why have I this problem? How can I solve it?

Tnx

Andrea

share|improve this question
add comment

1 Answer

You have rogue whitespace somewhere - maybe in functions.php, maybe in wp-config.php, maybe elsewhere. This is a common problem. You need to locate and remove the whitespace.

share|improve this answer
    
now I will see if I have this withespace...the strange thing is that if I don't use permalink I can open the feeds url as this: www.scorejava.com/?p=5/feed and I have noe error –  AndreaNobili Apr 11 '13 at 10:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.