Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a favicon that is a remnant of a disactivated wordpress theme. I can't find the favicon file in the theme folder, or the wordpress or server root.

I have added my own reference to a new favicon, but the old one is still displayed.

<link rel="icon" type="image/png" href="http://www.steve.doig.com.au/wordpress/wp-content/themes/grid-focus-public-10/images/favicon.ico">

My site is here.

Edit: Favicon is New Favicon

share|improve this question
    
I see your in Aus like me! –  Benny Feb 16 '11 at 6:16
    
if your mime type is PNG .... then do not specify an ICO.. –  edelwater Feb 16 '11 at 6:31
    
We just discussed much of the favicon topic in wordpress, probably you'll find an answer to your question in How to change the WordPress favicon? –  hakre Feb 16 '11 at 9:01
    
I've produced a new PNG image, uploaded it, and repointed the header link to it, but I can't see it yet (although the old icon is gone). Have I done something wrong? –  Steve Feb 17 '11 at 3:40
add comment

3 Answers

up vote 4 down vote accepted

The default favicon location on your server gives a 404:

http://www.steve.doig.com.au/favicon.ico

Your blogs homepage source-code related to linking to another location is:

<link rel="icon" type="image/png" href="http://www.steve.doig.com.au/wordpress/wp-content/themes/grid-focus-public-10/images/favicon.ico">

Note: The file suffix is .ico which normally stands for an Microsoft Icon file. But names are not interesting for that. The type="image/png" is correct here, it's a PNG file.

Your blogs server does return the following mime-type header for that linked favicon:

Content-Type: image/x-icon

Note: That information is wrong. The file's mime content type is acutally ìmage/png. Please reconfigure your server, rename the file to .png or convert the image in that file into the image/x-icon type (you can choose only one of these three options, the last one is the one I would do).

Suggestions

  1. Use a program that is able to properly save the microsoft ico file-format. Don't use a PNG, use a true ICO.
  2. Place your favicon.ico file then into the root of your server.
  3. Modify the links' href to the new location.
  4. Delete any old favicon.ico files from your server, delete your browsers chache, it's history etc. . Then restart your computer. The old favicon should be gone next time you visit your page on that computer.

You'll find more details in How to change the WordPress favicon?

share|improve this answer
    
After seeing this answer, I feel ashamed about mine :P Excelent job! –  Fernando Briano Feb 17 '11 at 4:00
add comment

I'm seeing this favicon when entering the site: http://www.steve.doig.com.au/wordpress/wp-content/themes/grid-focus-public-10/images/favicon.ico

enter image description here

Have you hard reloaded the website? Have you cleared the browser cache? Try looking at the site on a different browser.

share|improve this answer
add comment

I see an 'S' on a white background.

If you are still seeing the old favicon, it maybe your browser cache/history that is storing the image and matching it against the URL/domain.

Try looking on a different browser with an empty cache/history.

share|improve this answer
    
pushed submit at the same time as Fernando - didn't mean to repeat answer :) –  Mike Hudson Feb 16 '11 at 5:47
    
Yeah, that happens pretty often, don't worry about it. –  Fernando Briano Feb 17 '11 at 4:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.