Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am using WordPress for a technical developing blog.

I am using the base WordPress editor to write my articles (not using other plugin)

I am using the SyntaxHighlighter Evolved Plugin to enter code snippet inside my blog: http://www.viper007bond.com/wordpress-plugins/syntaxhighlighter/

I am experiencing a strange behavior when I enter XML code snippet.

I enter the code snippet passing into te textual view in the editor and inserting here the following code:

[code language="xml"]
my XML code here
[/code]

Ok, if I save the articles when I am into the textual mode of the editor it automatically modifies the xml code by eliminating most of the information in this code snippet.

Instead seems that if a switch the editor in the visual mode and here I save, I don't lose information and the code snippet is correctly shown in my article.

I don't think that this is a problem of the plugin but I think that maybe it depends by some security settings in WordPress or in the editor...

Do you have some idea? how can I solve it?

share|improve this question
    
Is your theme calling wp_footer()? –  vancoder Apr 3 '13 at 23:17
    
in my index.html I call <?php get_footer(); ?> but not wp_footer() what does it anyway? –  AndreaNobili Apr 4 '13 at 8:19
    
ok...I have read the difference from get_footer and wp_footer...in my footer.php file I have wp_footer() but I think that this is not the problem –  AndreaNobili Apr 4 '13 at 8:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.