Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have copied the HTML page content to the pages of the WordPress. The words have shown up under Preview but all the CSS and styling are gone. I have also imported the style.css into the Theme folder.

My question, why my contents missing their corresponding CSS?

share|improve this question
    
This is going to be difficult to answer without more information. Is the stylesheet loading? Do you have a link to your site? –  s_ha_dum Apr 1 '13 at 21:12
1  
Please provide a link to the site, with the little information you have provided my guess is that you aren't linking to your css file properly. –  Josh Mountain Apr 1 '13 at 21:45

1 Answer 1

Do you have this code corresponding to the style.css file that is in your main theme folder?

<link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" />

If you want to link to another name other than style.css or you have a different path you would want to use:

<link rel="stylesheet" href="<?php bloginfo('template_directory'); ?>/pathocss.css">
share|improve this answer
1  
You should be using wp_enqueue_style instead of hard-coding stylesheets into the theme. –  s_ha_dum May 21 '13 at 18:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.