Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I transferred a website to VPS and when I open that website, the home page takes too long to load, for me its taking 30-35 secs just to display the home page, but when I navigate the internal pages it loads in normal speed, I also tried this when all of my plugins were deactivated, but no change, it was taking time to load.

share|improve this question
    
what's your home page like? code? and does it have lots of DB calls? –  Bainternet Feb 15 '11 at 11:51
    
its just a normal website, you can check this out, u-k.in –  ntechi Feb 15 '11 at 11:58
    
saying its just a normal website doesn't help. wheres the database, what else is happening on the server? what happens if you create a php page with lots of calls into a database, do you get slowdown? what happens when you install a cache, does this sort things out? what do your apache logs say? –  anu Feb 15 '11 at 12:15
    
@anu I mean to say that this website was not having any trouble in opening the homepage in previous shared hosting, when I transferred it to VPS, it suddenly started taking time in loading, and the word normal website means its just a basic info website not too many databases call are made, I have one more website on this VPS which works fine, so I don't think their is something wrong with VPS, their is some kind of problem with wordpress –  ntechi Feb 15 '11 at 12:20
    
@anu when I tried w3 total cache plugin it was taking more time to load, when I deactivated it took less time to load –  ntechi Feb 15 '11 at 12:23
show 6 more comments

4 Answers 4

up vote 1 down vote accepted

There was a thread on wp-hackers in December which could be related: Avoid query_post on frontpage on wp initialization. You may give Sergey Biryukov’s code a try:

I was able to cancel the initial query with this code in the active theme's functions.php file:

function cancel_first_query() {
    remove_filter('posts_request', 'cancel_first_query');
    return '';
}
add_filter('posts_request', 'cancel_first_query');
share|improve this answer
    
is my question related to this? cause I just transferred from shared to VPS and started this website, –  ntechi Feb 15 '11 at 12:00
    
@ntechi I’m not sure; I just think it it may be possible. A good database cache could help too. –  toscho Feb 15 '11 at 12:06
    
I tried w3TC but it gave bad results, it was taking more time in loading –  ntechi Feb 15 '11 at 12:23
    
@ntechi As long as you are logged in you don’t get cached pages. You have to log out to see a difference. –  toscho Feb 15 '11 at 12:45
    
+1 on this. Just visited the link and got 4.7sec. for the whole front page/home. –  kaiser Feb 15 '11 at 16:08
add comment

If your normal pages are loading quickly, the calls to the database are probably your culprit.

I would have a look at some caching options for your content. They'll render the page once as an HTML document for your logged-out visitors. Read the descriptions and see if they'll be a good fit:

http://wordpress.org/extend/plugins/wp-super-cache/ http://wordpress.org/extend/plugins/wp-cache/

share|improve this answer
add comment

Your site loads normally for me. It could be something with your own ISP too. Also, try changing your theme and see if the issue is still there.

share|improve this answer
add comment

Make sure you install FIrebug and myabe that YSlow script to see whats holding it up. GO to NEt tab and click ALL, it gives you load time of each dependency.

Sean Internet Marketing Guides

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.