Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I just tried an automatic upgrade of List Category Posts plugin to version 0.17.2 on WordPress 3.0.5. I think I had 0.17.1 before. It installed but failed to activate:

Plugin could not be activated because it triggered a fatal error.
Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /hsphere/local/home/carrollp/clanecommunity.ie/wp-content/plugins/list-category-posts/include/CatListDisplayer.php on line 10

If I understand correctly author has requested issues be posted here.

I've never debugged WordPress before. Appreciate any help. My site home page is relying on this plugin. Thanks!

share|improve this question
    
Had same problem with the update. It does not work with PHP 4. Reverting to 0.16 fixed problem, but you might consider supporting PHP4 in the new version. –  user3183 Feb 15 '11 at 13:52
    
PHP4 support will phase out after the next release of WordPress (3.1), so this could be a good opportunity to upgrade to PHP5 :) –  Fernando Briano Feb 15 '11 at 19:46

1 Answer 1

up vote 2 down vote accepted

Yes, I've asked for issues to be reported here, so that you can get answers from the larger community of WordPress users and developers at WordPress Answers.

Regarding the issue, other user also reported it, and it is due to the webhost using PHP 4. Line 10 of CatListDisplayer.php declares a private attribute. PHP 4 doesn't have public, private or protected accessors.

Is there a way to ask your webhosting provider to update your server to PHP 5?

The other possible solution is to download the previous version of the plugin: 0.16, which doesn't use Object Oriented PHP.

share|improve this answer
    
Hola Fernando. I can ask, but it may be several days before I get a response - and that might be "No" :). In the meantime I guess it is time for me to learn how to manually install plugins. I see I can get previous versions on WordPress.org. Do you expect 0.17.1 would work, or should I go back older. Gracias! –  jmkie Feb 14 '11 at 21:44
    
Ah. I just see your updated answer. Perfect. Will try that. –  jmkie Feb 14 '11 at 21:46
    
Hola jmkie! You should install version 0.16.1. Manually installing a plugin is pretty easy. Just download the zip file on: downloads.wordpress.org/plugin/list-category-posts.0.16.1.zip. FTP into your host, and go into yourblog/wp-content/plugins/. There should be a list-category-posts folder there, just delete it. Then unzip the "list-category-posts" folder from the zip file you downloaded, and upload it to yourblog/wp-content/plugins. –  Fernando Briano Feb 14 '11 at 21:47
    
You can find more info on manually installing plugins on this link: codex.wordpress.org/Managing_Plugins#Manual_Plugin_Installation –  Fernando Briano Feb 14 '11 at 21:48
    
0.16.1 Working fine again. Many thanks for the speedy and detailed response. –  jmkie Feb 14 '11 at 21:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.