WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently noticed that Wordpress tries to auto-complete a URL when it's not submitted in its entirety. E.g. I have a post URL that looks like this:


If I browse to the following URL:


I can see that the URL is submitted to Wordpress but that Wordpress is doing a 301 redirect to http://www.mysite.com/some-post-title.

How can I disable this behavior?

share|improve this question
A tested solution that does not disable the whole canonical URL system but only disables the autocomplete "guessing" part is outlined here – Hauke P. May 20 '14 at 14:56
up vote 10 down vote accepted

I believe that is the redirect_canonical function hooked to template_redirect. You should be able to disable it with:

remove_filter('template_redirect', 'redirect_canonical'); 

But you should really think about whether you want to do that as it is fairly complicated and performs some important SEO functions:

Redirects incoming links to the proper URL based on the site url.

Search engines consider www.somedomain.com and somedomain.com to be two different URLs when they both go to the same location. This SEO enhancement prevents penalty for duplicate content by redirecting all incoming links to one or the other.

Prevents redirection for feeds, trackbacks, searches, comment popup, and admin URLs. Does not redirect on non-pretty-permalink-supporting IIS 7, page/post previews, WP admin, Trackbacks, robots.txt, searches, or on POST requests.

Will also attempt to find the correct link when a user enters a URL that does not exist based on exact WordPress query. Will instead try to parse the URL or query in an attempt to figure the correct page to go to.


The following might kill the autocompletion without messing with the SEO component, but I can't promise that. The code is barely tested as I have never wished to disable this. I'd really have to study redirect_canonical to be sure of anything.

function kill_404_redirect_wpse_92103() {
  if (is_404()) {
share|improve this answer

This seems terribly irresponsible, to have this "guessing" occur automatically. I would be much more open to it if there were some means of defining which was the correct page to go to.

I have numerous pages that are built as a sequence, and this auto-guessing is incorrectly choosing to respond with pages that are (randomly?) somewhere in the sequence, as opposed to the starting page.

UPDATE: This is known behavior, and is being considered here: https://core.trac.wordpress.org/ticket/16557

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.