Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am finding some problems uploading a WP site from my local webserver to the official online webserver.

The situation is the following one, on my local web server:

  1. I have install WP website on my computer
  2. I have configure it
  3. I have custom a template

After, I have upload this site in a folder on my official online webserverm I have took the local database on the online database using PhpMyAdmin (to export the local databse on a file and then to import it on the online database)

Finnally I have changed the file wp-config.php changing the MySql connection settings and putting here the settings related to the official online database.

When I try to open the website it appears to me, here you can say how: http://www.scorejava.com/wordpress/

Ok...seems good but there is two problems:

  1. If you try to open an article it is not open the article on the online server but in the localhost server, infact open this URL: http://localhost/wordpress/?p=81

  2. If I try to open the administration pannel opening this URL: http://www.scorejava.com/wordpress/wp-admin/ I obtain a white page

I don't know if these two problems are related togheter but I think that all may depend due to a problem of location path...

I think that somewhere there is some settings that specify the URL (that can't be localhost...), but (if it is so...) where is this setting? in some file or in the database?

Some one have an idea? Can you help me?

share|improve this question
    
localhost/wordpress/?p=81 will only work on your local machine. It won't work for anyone else. There should be no links to localhost on your live site. –  vancoder Mar 21 '13 at 21:26
1  
Please, don't Multi-post the same Question across the network. –  brasofilo Mar 21 '13 at 21:45

2 Answers 2

You have to change siteurl and home in the wp_options table to your server address.

Just go to the table wp_options in phpMyAdmin, look in the option_name column for siteurl respectively home and overwrite their value in the option_value to http://www.scorejava.com/wordpress in your case.

share|improve this answer
    
now the articles are correctly open but I still have the problem of the withe page when I try to open the administration...some ideas about it? –  AndreaNobili Mar 21 '13 at 20:07
    
I still have white page, no error message :-/ –  AndreaNobili Mar 21 '13 at 20:49
    
Doh! I meant define('WP_DEBUG', true);. –  vancoder Mar 21 '13 at 21:19
    
ok, now I obtain the following error message: Notice: register_sidebar_widget è deprecata dalla versione 2.8! Utilizzare al suo posto wp_register_sidebar_widget(). in /home6/onofrior/public_html/scorejava/wordpress/wp-includes/functions.php on line 2839 what means? –  AndreaNobili Mar 21 '13 at 21:42
    
It means something is using deprecated code, but I don't know offhand why that explodes your site so seriously. I'm beginning to think your issue is too localized for us to be of assistance. –  vancoder Mar 21 '13 at 21:50

have a look here

After DB upload you just need tu run the script and replace your Local URL with Online URL

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.