Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I am trying to set up a multilingual site using wordpress. I went through Each language in its own WordPress installation and decided to use this option:

Plugins like Multisite Language Switcher and the newcomer Multilingual Press link together separate WordPress network (multisite) installations for each language by pinging back and forth..

Now I installed the Multilingual Press and set up a network. The URL of my site was wordpress.private.net and next on is it.wordpress.private.net. Both domains are served from same folder. But still when I visit the it.__ site it shows in English language and that too without all the posts.

I get this notice on network dashboard

You didn't setup any blog relationships! You have to setup them first to use Multilingual Press. For this, go to Network » Sites » and choose a blog to edit. Then go to the tab "Multilingual Press" and set up the relationships.

But there is no option to set up the relationships in the tab "Multilingual Press". Please guide me where am i going wrong?

Any other way to set up is also welcome.

My goal is to run my WordPress site in two languages.

share|improve this question
add comment

1 Answer 1

  1. Go to wp-admin/network/sites.php.
  2. Edit one site, and set a language for that blog:

    enter image description here

  3. No do the same on a second site. There have to be two sites with an associated language. And then you get the relationship setting below on the same page after hitting F5 one time. This will be fixed in the next release.

    enter image description here

I am helping out on that plugin now, implemented synchronized post meta data just ten minutes ago. :)
New docs are the next point, so if you have any questions or suggestions feel free to ask me here or per private contact.

share|improve this answer
    
I am not getting the blog relationship section in Multilingual press –  Sankalp Mishra Mar 21 '13 at 9:39
    
I have made a virtual server for second domain pointing to the same folder. Also there is an entry for second domain in host file. Still my second domain shows english instead of italian and does not has post of first domain. Please help!! –  Sankalp Mishra Mar 21 '13 at 9:44
    
@SankalpMishra I'm on it. Please make sure you have no blog without an associated language. –  toscho Mar 21 '13 at 10:09
    
I have both the blog with there associated languages! –  Sankalp Mishra Mar 21 '13 at 11:11
    
I have tried all the steps thrice in 3 setups. Didn't worked out even once. Please help!!! –  Sankalp Mishra Apr 12 '13 at 13:50
show 4 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.