Sign up ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

If I'm setting up a brand new multisite installation with WordPress in it's own folder (say /wp/) why can't I configure the network to use subdomains instead of subfolders?

Currently, if I try to setup the network with the WordPress core in it's own folder I'm not allowed to choose between a subdomain-based or sub-folder based network. I must use sub-folders. What are the technical reasons for this?

I've scoured trac and Google for an answer to this question with no luck. A more detailed explanation than what is provided on or would be greatly appreciated.


share|improve this question

1 Answer 1

up vote 2 down vote accepted

I figured it out. The fact is, a network can use subdomains or subfolders, even when WordPress is installed in it's own folder as long as the main site's HOME URL is set to and not to the sub folder location.

Here's an example:

I setup a clean install of WordPress using Mark Jaquith's WordPress Skeleton which places WordPress's core files at However, when trying to run the initial install script, WordPress chokes on its own redirects. (It keeps trying to load instead of Maybe a bug report for another day?)

To get around that, I manually typed in the correct path to the install script ( By doing this, WordPress sets the HOME URL to instead of just (Which makes sense, really.)

By changing the site's HOME URL to, I am now able to choose a subdomain or subfolder installation when setting up the multisite.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.