Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I have a custom post type 'BLOG'. I created archive-blog.php file to display archives. Also I register a taxonomy with it named as 'blog-category' and created a page 'taxonomy-blog-category' while clicking on this taxonomy terms redirects me to the 404 page. Seems permalink problem. I have saved permalinks and rewrite_flush() but that also doesn't work. Any help would be appreciated. Hope I'll get a positive response from your side. Thanx in advance.

share|improve this question
    
What is url of your taxonomy terms? –  Vinod Dalvi Mar 19 '13 at 6:41
1  
First check is there any post and taxonomy that has been same named as your new taxonomy. –  user29146 Mar 19 '13 at 7:34
    
Hi thanks for helping me out the url of the term and taxonomy is this example.com/category/category-1 where category is the taxonomy and term is category-1 –  Akanksha Sharma Mar 21 '13 at 10:15
    
Yes, there is another taxonomy is registered with the same name. But they are registered with different CPT –  Akanksha Sharma Mar 21 '13 at 10:19

1 Answer 1

The taxonomy having rewrite rule with the name as 'category'. I changed it to different name and named it as 'blog-category', it will work for me in my case.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.