Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

When i put special characters in text field on wordpress themes option then it's gonna add some slash characters Like if I put

It's  

then its show

It\'s. 

How i solve that?

share|improve this question
    
are you trying to add the characters to a word in a php file? –  Aliyah Mar 14 '13 at 20:08
    
No, I'm trying on themes option panel. Maybe this option panel does not sanitize special characters. –  Tawhidul Islam Mar 14 '13 at 20:18
    
Can you screenshot it? I cant picture your dillema. –  Aliyah Mar 14 '13 at 20:20
    
How do you save the options? Add the code to your question. –  toscho Mar 14 '13 at 20:28
    
show 2 more comments

1 Answer

You need to escape the apostrophe yourself. Two ways to escape apostrophes is to do this:

It"'"s

Or this:

It\'s

If you do not escape them yourself, you likely end up with the problem you're having now. So try one of these methods in your options panel text box and see if that answers your question.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.