Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

Having checked my site with google page speed and gzipwtf.com I have noticed that my css and js files are not getting compressed (although html is).

Have tried unchecking " Prevent caching of objects after settings change " and have thus removed query strings from these files but that has had no effect.

Have also tried adding the following (both above and below wordpress rules) in htaccess to no effect also:

# BEGIN GZIP
<ifmodule mod_deflate.c>
AddOutputFilterByType DEFLATE text/text text/html text/plain text/xml text/css     application/x-javascript application/javascript
</ifmodule>
# END GZIP

Would any one have any advice as to what I may be able to do to rectify this?

Many thanks

share|improve this question

put on hold as off-topic by mrwweb, Pieter Goosen, Johannes Pille, birgire, Wyck yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Your question should be specific to WordPress. Generic PHP/JS/HTML/CSS questions might be better asked at Stack Overflow or another appropriate site of the Stack Exchange network. Third party plugins and themes are off topic." – mrwweb, Pieter Goosen, Johannes Pille, birgire, Wyck
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
It looks like mod_deflate is not present or it is not enabled. You may want to check with your host. HTML compression works, because there are other ways to compress PHP output, rather than using mod_deflate at the server level. –  Pothi Apr 1 '13 at 15:45
    
@pothi I believe it is enabled, I checked using phpinfo and deflate is shown. Am I missing something? –  noelmcg Apr 1 '13 at 21:18

1 Answer 1

up vote 0 down vote accepted

Thanks to @Pothi Kalimuthu I checked with my hosting company to see if mod_deflate was enabled, and it wasnt. This was the problem.

I mistakingly believed that it was by incorrectly reading the results of phpinfo.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.