Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm encountering an issue with wordpress 3.5.1 (french language). I can't insert images in posts/pages or whatever.

When i access the media library from the button "insert a media" (while editing a post), the media library is empty, so i can choose an already upload image to insert. If i upload an image from my computer, the image loads well (and get upload in the uploads directory), but when i insert it in the post, the media box close and the image don' insert.

On my local development environnement, all works fine, i've try all basic steps to identify the issue with no results. I wonder if it could be an issue from my web host.

Any ideas?

share|improve this question
    
I'm having the same problem with the English language version too... and only very recently. Encountering it on both my local and live servers (so MU and not-MU). Just re-downloaded 3.5.1 from wordpress.org, disabled all plugins, including mu plugins, switched to default theme and still get Uncaught TypeError: Property 'scrollTo' of object [object global] is not a function in my console when I try to insert into post. Please post back here if you find a solution. I will do the same. –  helgatheviking Mar 22 '13 at 12:33
    
FWIW- I just solved this for myself by disabling all of Chrome's browser extensions. For me, the Better Popup Blocker extension was preventing the insert into post from working correctly. –  helgatheviking Mar 22 '13 at 15:10
    
I'm having the same issue. Uploading images into my media library works. However, when I click "Insert into Post" to embed an image in a post I am editing, the popup closes, and nothing happens. Console returns no errors or messages - nothing. Kind of spooky. I've perusing all over the internet for a solution, but I can't find one. PLEASE somebody solve this. Disabling plugins in Chrome does nothing for me. –  David Faux Apr 8 '13 at 3:45

3 Answers 3

Try to disable any plugins that may be interfering with it and also check if this occurs on a different browser.

share|improve this answer
    
I had the same problem long time ago and disabled all plugins then enabled one by one and found that the problem was with the plugin, I can't remember the plugin name. –  Core May 28 '13 at 6:13

Have you enabled debugging in wp-config.php

change define('WP_DEBUG', false); to define('WP_DEBUG', true);

This will cause WordPress and php to generate a lot more error messages.

With very little detail to go on, my first guess would be file permissions on the upload directory on your server.

share|improve this answer

I have this same issue (can upload fine, but not insert into post). It appears that for me I'm changing the location of my wp-content folder by using a combination of these config values:

define('WP_CONTENT_FOLDERNAME', 'media');
define('WP_CONTENT_DIR', ABSPATH . WP_CONTENT_FOLDERNAME );
define('WP_CONTENT_URL', 'http://domain.com'.WP_CONTENT_FOLDERNAME); 
define('WP_PLUGIN_DIR', ABSPATH . WP_CONTENT_FOLDERNAME . '/plugins' );
define('WP_PLUGIN_URL', WP_CONTENT_URL.'/plugins');

By commenting these back out, all things return back to normal and I'm able to then 'insert into post' again. It may be related to this track bug, which I just commented on.. https://core.trac.wordpress.org/ticket/24143

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.