Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm new to WordPress. I started the site as good with folder name wordpress. After I changed the folder name from wordpress to test. And also change the siteurl from http://localhost/wordpress to http://localhost/test in wp_options table. And I modified the guid with this refer.

My problem is, still I click any 'post' or 'comment', that goes to http://localhost/wordpress/?p=7#respond page only. I want that's goes to http://localhost/test/?p=7#respond.

Anyone can?

share|improve this question
1  
have you re-saved your permalink settings? –  david.binda Mar 7 '13 at 11:11
1  
The GUID is not used for permalinks, it isn’t even an URL (just happens to look like one). –  toscho Mar 7 '13 at 11:44
    
@toscho i got your point. thanks. and thanks david.binda –  KarSho Mar 8 '13 at 4:04
add comment

4 Answers

up vote 2 down vote accepted

After changing siteurl, Go to admin panel and update permalink structure once and check.It will start working with new folder name.

Hope it helps

share|improve this answer
    
but, I didn't change 'Site Address (URL)' in admin panel> Setting>General. –  KarSho Mar 7 '13 at 11:21
add comment

See the Moving WordPress page in the Codex.

When your domain name or URLs change - i.e. from http://example.com/blog to http://example.com, or http://example.com to http://newexample.com - there are additional concerns. The files and database can be moved, however references to the old domain name or location will remain in the database, and that can cause issues with links or theme display.

There is a special script, Search and Replace for WordPress Databases Script.

If you are a developer, use this option.

Run this script to safely change all database instances.

share|improve this answer
add comment

Try resaving permalink setting and Instead of manually changing url you can change it by using this serach and replace wordpress plugin.

share|improve this answer
add comment

You should change your home field to http://localhost/test too in your wp_options table.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.