Take the 2-minute tour ×
WordPress Development Stack Exchange is a question and answer site for WordPress developers and administrators. It's 100% free, no registration required.

I'm making a fairly large (for me) e-commerce shop with Woocommerce. The shop has ±1300 products and will be going to ±2000 products. There are also ±2500 Product Tags.

I've had speed problems on a shared hosting server; updating posts took over 1 or 2 minutes from time to time. The front-end of the website has always been really speedy.

So I've moved the server to a VPS server with 4 processor cores of 4.9Ghza and 2048 Mb Ram. There's no visitors on the website; no traffic problems. As said before, the front-end is really snappy. Every pages loads in under two seconds.

However, certain things are really slow in the dashboard/admin of Wordpress. Everything in the dashboard is really quick and responsive. Changing from posts to pages, to settings, to listing products in Woocommerce: all very snappy.

Updating products (a Woocommerce custom post type) is quick when changing the_content and adding text in custom fields. Every product has a lot of custom fields (≠50) that are served via the plugin Advanced Custom Fields. No problems there.

The BIG problem comes when I try to add 'Product Tags'. When I add one or more Product Tags, they appear quickly in the dashboard sidebar box. However, when I then try to Update the product, the spinning Wordpress wheel keeps spinning forever. The website hangs for one to two minutes and than finally update the post. I can try to access another part of the Wordpress dashboard, before the update is complete, but it doesn't react anymore. Only restarting the browser helps when I did that.

There's also an important issue with the 'Product Tags' menu item under 'Products' in the sidebar. I tried to add tags from there, but it blocks the site as well in a different manner. I can fill out the field to add a Tag and than hit 'Add new product tag'. Then I get NO message whatsoever that the tag has been added... the text of the new tag stays in the text field too. The button can be clicked multiple times, but it looks like nothing ever happens. When I restart the browser, the new tag has been added though.

Plugins: 14 active. It doesn't change when I turn off all other plugins besides Woocommerce.

Could you please help me out?

share|improve this question
    
Hi, I found out that this has something to do with the number of terms in any taxonomy, whether it's a Woocommerce taxonomy, a custom taxonomy or the default Wordpress taxonomies like Tags or Categories. Once I go past 100 terms in a specific taxonomy, adding a new term takes a lot more time... How come? Bart –  Bart De Vuyst Mar 4 '13 at 12:03
    
hmmm could you reformulate your question to be more concise? Right now it has no structure, state the question clearly in 1 sentence, then explain briefly, followed by more in depth detail –  Tom J Nowell Mar 5 '13 at 10:24
    
Also which version of WooCommerce are you using? Also I'm assuming WordPress v3.5? –  Tom J Nowell Mar 5 '13 at 10:25
    
Also it should be clear exactly what an answer to this would be, right now it's not clear how one would answer this appropriatley, and the question is in danger of a "not constructive" or "too localized" closevote in its current form –  Tom J Nowell Mar 5 '13 at 10:25

4 Answers 4

The bigger the table, the more work adding a term becomes. There's nothing unusual about it, it's a matter of scale.

Consider this:

I'm at a pie eating contest. Once I go past 100 pies in a specific contest, eating a new pie takes a lot more time...

To diagnose what is slowing things down, you will need to monitor what runs on the various update hooks, and run profiling tools. It could be caches being regenerated, etc, poorly configured mysql+apache setup.

Eitherway, things will slow down as you ramp up the number of items in your Wordpress install, and the plugins and features you have turned on will compound that effect.

Also consider doing a repair and optimise on your tables.

share|improve this answer

Lost track of this one. It turned out to be a major Woocommerce bug. Updating to Woocommerce v2 fixed all this. Lost quite some time searching for a solution elsewhere, where it was just Woocommerce doing this somewhat wrong. Thanks anyhow!

share|improve this answer

The problem can be found in the way Woocommerce updates taxonomies in the pre-2.0 versions.

Here's a link to the diff file that fixes admin/woocommmerce-admin-functions.php.

The code was reordering taxonomy every time a new term is added which will bring the entire site down and cause numerous cascading errors to the updating process of your site. You will not be able to import or update terms as their code includes custom taxonomies.

share|improve this answer

maybe it's a jquery issue? does you notice slow down, freeze when your are adding tags to your post?

if yes, maybe you can try deactivate the jquery suggest in wordpress using something like that (in functions.php of your theme):

function deregister_autosuggest() {
    if( is_admin() ) {
        wp_deregister_script('suggest');
    }
}
add_action( 'admin_init', 'deregister_autosuggest' );

try it and tell us if it works ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.